Points Snaps To Previous Pattern With Disabled Snap

Might not be a bug but at least irritating. I have disabled the snap setting in the automation editor and want to finetune a point at the start of the next pattern, where the previous pattern already has automation. It’s impossible to finetune the point, since it’s always snapping around the value of the previous pattern. The only way is to directly edit the value. Disabling snap should also disable this behaviour?

Snap settings only applies to time -> grid, lines and so on.
But you can bypass the value snapping by holding down control.

Does not work for me, that’s what i tried first. It still snaps in the area of the previous pattern point.

Tried again, but this works just fine here.

Has anybody else the same problem?

Renamed my preferences folder and in a clean Renoise it works as you say, will mail you my files. Edit, wait…

It does not work when DRAW is enabled.

Move this back to the bug report forum? One can bypass the snapping with LINE mode enabled and without any mode selected, so i see no reason why it shouldn’t work with the DRAW mode for consistency. Would still consider this as small bug.

Yips. Fixed that for the next update.