Ppc Vsts?

3 character acronyms non-searchable upon forums, or i would have looked around.

having a confusion.

i just read Keith303’s thread on ppc vst on intel macs.
was about to post there but see it’s not all really related.

my linux smallbox went wonky this morning.
so, until it unwonkifys.
i installed 1.9.1 on my ppc ibook (ver. below) today. an having trouble with ppc plugins on a ppc!
hah! imagine that.
my question is
do the ppc plugins not work with renoise across the board anymore or is this a local issue and i goofed something up with my guerilla fingers?

Basically: PPC plugins work on PPC computers. Intel plugins on Intel computers. Universal binary Plugins work everywhere as they contain both, the PPC and Intel versions.

But maybe you could tell us a bit more about what exactly doesnt work for you, so that we can help you?

i’ve tried a few things most all showing different results.

first off,
i did notice there was not the usual installler. unpacking renoise it dropped the renoise_reg.app

expecting it to run the installer i ran it from the desktop, instead it loaded renoise. could it be as simple as a broken package?

i just now downloaded it again and same happening.


i have a bunch of plugins in /library/audio/plugins/vst

when i first noticed this, i saw in the vsti list a blank field. which is not common. so i selected it, hence crashing renoise.

the only thing that has changed since the installed osx renoise beta was that i installed the ub mda plugs. since this next part i have removed them.

i first tried setting the vst finder in prefs to only the above location, excluding it from looking in the empty user/vst directory. it allowed 5 vsti plugins to load and 2 vst effects. this fluctuated between a few different plugins while the blank stuck around, while trying different locations such as /library/audio/plugins/

i also went through and removed everything i could find relating to renoise plist and removed the cached vst xml.in
removed the .app and placed a fresh one. with all prefs defaulted.
getting same symptoms.

also another thing: the loaded vsts & vstis have either an .xsym or an .xmap suffix. which is curious! the blank is in both vst and vsti.

will try reinstalling a few to see what difference it makes.

thanks for bearing with me, i have the CRS, the one where i can’t remember ****! :P

No you have to drag it to your applications folder and that’s it.

okay, yeah i put it in with the others writing over the beta, before i deleted the 1.5 & 1.9 & 1.9.1 then deleted some plists an such.
that i could find in the finders search.

i even rebooted!

its good, if i need to render anything from the plugs, will do in something else.
cuz this doesnt make any sense.
i must have the new apple virus!
the one
with the only way to fix it is to buy the latest model! ;D