Problem loading MIDI-files

Hi. Just the other week I could load.MID files into Renoise. Now it doesn’t work at all.

Tried loading midi files that I know I’ve loaded before, but for every single one I now get “Unknown or unsupported song filetype”.

I tried re-saving some both as Midi format 0 and Midi format 1, without success.

Midi-loading support removed?
Attached one of the midi-files.


Ah, you’ll have to make sure you click browse and then ‘attach this file’ hyperunknown :slight_smile:

(Other thing just worth mentioning… What version of Renoise are you using? :slight_smile: )

Well that’s… new.

I’ve always used file->open for midi files, but as long as it works it doesn’t matter where I have to open them.

Thanks a lot for the fast answer, appreciated :smiley:

+100 and For President™

(I’ll have to think about this thread… :slight_smile: )

So long as you got it to work, that’s the important thing hyperunknown!

(I’m a legend and now I could be in the running for president :slight_smile: )

Well that’s… new.

I think 4Tey was referring to the fact that there was no MIDI file attached to your post?

Regarding that file - it should definitely import if a previous version of Renoise could load it.

In Renoise, have you tried right-clicking in the file browser and ‘load with options?’

(the latest version, 3.1, can merge MIDI into the existing song instead of creating a new document)