Problem With Rubberband In 2.7

I installed the 2.7 version of Rubberband and encountered an error. I’ve tried everything from manually reinstalling Rubberband to reinstalling Renoise.

The script worked fine when I had 2.6, but since upgrading to 2.7 I get an error that tells me my installation is bad or my system is causing a problem. I don’t really know what to do.

Has anyone had this happen before?

when filing a bug-report, it is a smart thing to be a bit more specific, so people can try to recreate the problem.
so, what are the steps you take to get this message? start with downloading the latest 2.7 version of Rubberband from, and describe from there.
also, try to make a screenshot of the error message, could be useful as well.

I download Rubberband, drag it into the Renoise window to install, load up a sample, CTRL+Click go to Process-> Timestretch/Change Tempo/Pitch Shift (none of them matter, still the same error.), then I get this.

Also I’m running on OSX 10.4.11, if that helps.

Yes, this is a known problem.

Basically, the rubebrband included with the script (1.5.0) doesn’t work very well with anything below OSX 10.6.

Try either manually upgrading or downgrading the binary? The file to replace will be located at: