Program Changes

it’s been forever since i used these and i searched and saw it has been reworked.
i tried putting the 92 in the right most panning column along with an 0001 but having trouble getting effect.
using the mdaJX synth. does the JX doesnt recognize the midi command?
TIA

I almost never used program changes, but I remember that some VST instruments did not respond to this kind of message if no note has been triggered together with the message, so also try if triggering a note together with the program change does the trick.

  
C-4 01 -- 92 xxyy  
  

it works incredibly nice this way shutting off the vsti during program change! :)

I’m having some troubles getting this to work for some reason.

what I’m trying to do is use Program changes to change snapshots in reaktor which i have loaded as a VST Instrument in renoise instrument slot 00. (According to the Reaktor manual this is the method that should be used)

so if i then want to trigger snapshot 45

I type code C-4 00 – 92 xx45

because in the renoise manual it states
" 92 - Program change, value in the effect-column (usually the last two bytes are used only (00 - 7F) "

bt if i use above code , renoise takes it as an arpeggiator, because it adds two zero’s for the xx.

So I must be doing something obvious wrong.
I’ve tried a whole bunch of variations, sort of trying my luck, but without succes.

any help would be appreciated.

If you really mean to trigger snapshot 45 you also have to specify the value in hex, 45 = 2D.

Yeah , that is the first obvious mistake i made.
I still cant get snaps to change though.

Is it right that when i enter the effect number (002D), that in the hints it says it is a arpeggiator?

no, if the hints says it is an arpeggio, you are doing something wrong.

are you writing the C2(*) in the panning column?

if LCTRL+LSHIFT+P opens a new column, that’s the panning column

you also must specify the instrument number.

example:

  
not in vo pa comm  
--- 01 -- C2 0010 => sends PC 10 hex  
  

(*) quoting Bantai:

Ah okay!

i was still using the 9x command which is stated in the manual , which is for 1.9 versions. Forgot about the changes when using 2.0 . . .

thanks a bunch, works like a charm!