Record Note Delays With Pitchbend/MIDI Data?

Not sure if its a bug or what.

In renoise 1.9 if I used my midi keyboard pitchbend samples would bend and it would look like picture 1

now it looks like picture 2, an adds some kind of groove

can I in some way control this myself ?


looks like the pitch bend has been recorded in realtime, hasn’t it?

the light blue column is the delay column, which indeed delays the event by 256ths of a row to better reproduce the human lack of precision in the realtime input and give better resolution

use the quantization by pressing the “Q” icon on the upper left in order to avoid the delay column to be filled with precise delay values;

this is clearly a [nobug], anyway I’m not sure if this is the most comfortable behaviour for pitch bend events recording: probably it would be better if Renoise never add delay values to the event when recording pitch bend values, what do others think?

yes, I forgot to say that…


on a second thought, I definitely think that adding note delays to pitch bend recording is bad, as it will add/overwrite undesired delays to any notes on the same note column: I can hardly think of any practical use of note delays with pitch bend

The practical use is more precision, right?
At slower scroll speed this is good.
But you are right about overwriting note delays. That should not happen.
Either the pitchbend should add another note column when that happens, or simply skip writing delays only on lines where it will collide with a note.

I agree. It shouldn’t record note delays. Also it shouldn’t be quantisized together with notes!

but what if you first write the pitch bend values, then manually add some notes in the same note column? then you should most likely remove the delay values; note delay values are for notes, I would not extend their usage to events such as pitch bend

Is that really a huge problem?
If you manually type in notes where there already is a xxC1 --xxxx you should know and see what is going on.
You can simply add another note column, or just delete the delay?

My vote goes to accuracy :)
This is not only pitchbend either… also modulation and aftertouch etc.
Just MHO.

well of course I can enable Q01 when recording pitchbend, I was just asking if it would be wiser to disable quantization completely when recording it, but it seems like it is not the case :)

[nobug] then

Well, what we could (maybe should?) do is expanding the number of voice columns - recording them in a new column, so that the recorded MIDI commands no longer conflict with already present notes, note commands. That would eliminate the problem and still gives you the possibility to not record without note delays via the quantize settings?

personally I would prefer not to automatically add new columns for such a task: I would rather prefer manually enabling Quantize to 01. Any other opinion?

This doesn’t work. If you record notes without quantization, then record MIDI controllers without quantizations on top you will end up in delaying the MIDI controllers with the delays from the previously recorded notes. I dont think that this behavior is expected / somehow useful.

hmm you are right… in such case I should manually enable Q01 and add a track…

is your solution like this?

when recording pitch bend,
if rightmost note column contains notes in the current pattern
then add new note column

if not, I think you may be in troubles if the user performs multiple recording sessions (in some cases Renoise could add columns “indefinitely”).

can this be performed in realtime even on big modules? this is another fear I have.