[recovered] Crash And Lost Work!

I was working on a tune and renoise crashed, i lost a few hours of work. when restarting renoise, it prompted me to recover the xrns and i said yes (i don’t have auto backups on) then renoise crashed again. now it’s no longer prompting me. are these recovery xrns’s stored anywhere?

since you use mac i’m not sure.
search for a CrashBackups directory i suppose.

use autobackup, even if it’s set to backup every half an hour or so.

no luck in finder :(

The crashbackups are located in the preference folders:

Windows XP: x:\Documents and Settings%username%\Application Data\Renoise%renoiseversion%
Windows Vista: x:\Users%username%\Application Data\Roaming\Renoise%renoiseversion%
MacOS: ~/Library/Logs/Renoise.log & ~/Library/Preferences/Renoise/%renoiseversion%
Linux: ~/.renoise/%renoiseversion%/

Could you please let us know what exactly you’ve done before the crash happens and send me both, the log.txt and the crachbackup song (taktik at renoise) ? I’ll try to see what I can do to recover the song but we’ll need your help to find out how and why this happened please…

thank you soooo much. i sent them just now.

the recovery xrns opened with no problems! still a mystery to me. hopefully this report helps fix any possible bug :)

As said above: the log might help, but you can help even more by letting me know what exactly you’ve done before the crash happened. As much you can remember - even if you think its not important.

I had been working on this tune for a number of days with no issues. my basic samples and two instances of Tal-UNO-60. The only addition I had made was an mp3 segment from an audiobook. editing worked fine; i trimmed a 10ish second clip and was attempting to place it, entering a repositioning a few times, then a crash.

also, when the original recovery opened last night, i saved is with a new name. this new file then wouldn’t open. thinking it was the mp3 segment, i removed it after opening the original backup xrns (which seems to be the only version opening) then resaved an xrns with this mp3 taken out and the new file crashes.

I’m happy that i have access to the recovery xrns, but any changes I make are then inaccessible. This is as much as i’m aware of from the incident. if you have a particular question, just shoot. I PMed the log and the recovery xrns. thanks taktik!

Have send you the recovered version.

Could you give me more details about what you called “was attempting to place it, entering a repositioning a few times, then a crash.” Especially what repositioning exactly means. Have you used the adv edit or inserted new lines somehow?

The crash happened because you somehow managed to place a line behind the 512 pattern lines boundary. We already had such a thing before, but never managed to replicate this issue, thus could never fix the problem. So I would be very thankful if we could try to replicate this so that this problem gets finally fixed.

At which pattern have you worked? How have you entered, repositioned that “clip”. With clip you mean an instrument? Any details can be helpful!

Or have you maybe merged some patterns?