Redraw Issue Linux/Lxde


I recently went away from gnome, and fell in love with lxde. However somethings fishy with renoise/lxde. Not sure exactly what triggers the problem, but it seems that it’s never there on boot and always there after a suspend (at least on battery).

The problem is that some parts of the ui doesn’t redraw correctly. I captured this with my phone, appoligize for the poor quality + at least here it plays back tilted 90 degrees:

I don’t have this problem when using other WM’s than lxde or other software than renoise…

LXDE is nice but quite new WM. Sometimes it behaves strange. I had the same problems and swiched to XFCE with Renoise and everything was fine.
Another option would be Openbox or Fluxbox.

I’m on linux lxde here at the moment - avlinux disto, I don’t have these sorts of video redraw issues. This issue is most likely related to the current driver being used by linux for your gfx card. what is the output of lspci ? If you’re using an Nvidia card you’ll be sure to install the run package directly from Nvidia… their search utility works great and you should be able to find plenty of information on installing the run package on the internets.

Hope this helps! I like lxde a lot too!

Ok, as suggested I switched to openbox, and it seemed the problems was gone. However, today it appeared again this time with openbox while being on stage. Not the kind of thing you wanna have to deal with just before a live performance :angry:

Anyways, I found this post, which seems to describe the exact same problem (with renoise, opera, xtern and urxvt) and suggests 2 hot-fixes:

  1. Use renoise without a wm.
  2. Run xcompmgr

I’m all for hotfixes at the moment, so I prepared for the no wm-route, and installed xcompmgr, I’ll report back if that “solves” the problem.

Meanwhile it would be nice to hear from one of the devs, if there’s any ideas or suggestions from the renoise camp?

NB: And no, I don’t have a nvidia card…
atte@vestbjerg:~$ lspci | grep -i graph
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 03)


if you have KMS enabled, have you tried disabling it ? it is pretty new feature, and on the intel gfx drivers is still not ready for heavy use.

btw, lxde uses openbox as WM ? so mainly that could be your problem.

have you tried running a different WM like fluxbox, or even evilwm ( that i prefer for very lightweight installs ) ? mainly to see if the problem is your xorg/gfx driver configuration or a specific WM quirk.

Dunno if I have KMS enabled…

Will try evilwm, however, since this only happens quite rarely, it’s hard hunt down, even by running another wm (hadn’t bit me for 2 weeks). That’s why I hoped it rang a bell in the dev team.

I only can say, that I use XFCE and something like that never happened to me …
O.k. I admit that I don’t go on any stages, so if it would happen it’s not that “ugly” as live on stage.

Btw. Openbox and Fluxbox both come from Blackbox.
LXDE is based on OpenBox, quite new and known not to be 100% stable yet
Evilwm latest news are from 2009
Icewm last publishment was mid 2010
XFCE latest release is from Jan. 2011 :)
XFCE has lower resource usage as Gnome or KDE
Unity is quite new

Decide yourself ;)

Btw. which distribution do you use?? Maybe the graphic driver of your distro is unstable?? Switching Distro or changing driver might help.