Relative JumpToRow

JumpToRow shall be relative dependent on how much rows it is in the pattern, so if you have 128 rows instead of 64, the JumpToRow32 shall jump to row 64 instead of 32 (and would rather be named JumpToRow1/2 instead maybe ;) and so on…

+1 to this idea! I almost never use patterns of length 64 so these keyboard shortcuts are useless to me…would be much more useful if they were changed to jump to 25%, jump to 50%, and jump to 75%.

EDIT: Okay, I’m an idiot. I just realized that they actually do behave this way. I just didn’t realize it since the keyboard shortcut said to jump to row 16 and I didn’t actually try it out…:x

Perhaps we should rename them to JumpToRow25p and JumptToRow50p.
Using % signs in variable values in CPP is pretty dangerous and may work quite confusing for developers.
(It is being used to define the place of a string or numeric value when it has to be read from a table and placed within the string-value where it is being used)