Render Selction in Renoise 2.0 Beta =way To Loud

when I render selection to sample …9 times out of 10 the rendered sample is distorted …way too loud …even when the auto adjust fader is activated…In other words …I don’ get what I hear …
To be honoust I really prefered the old way …

Maybe you’re experiencing the same thing I did a few months back. A sound that plays nicely “internally” is clipped when rendered?

Render selection does now indeed render the samples in such a volume, that if you would play them back on an empty track with no FX, it has the same volume like the original rendered selection. That was done for 2.0 because this was requested from many people.
If this leads too often in distortion (WAV files must be clipped, they have no dynamic range), then we should revert the change until we have an auto-gain mechanism?

I even got it with vst’s …when the vsti track is playing , no clipping is visible in the waveform window …however …rendering the track ( selection ) to sample introduces clipping , audible and visible in the waveform window…

I’d prefer to still have the current method as an option. I’m quite enjoying having what I hear rendered properly.

This part intrigues me. This thread may not be the best place to ask, but could this be elaborated on? I always figured that if it played without clipping @ 16bit 44.1kHz audio then a 16bit 44.1kHz audio .wav would be exactly the same… What exactly is clipped? :huh:

edit: I do appreciate that the rendered sample is the same dB as the original sound since this makes softer, low dB sounds more precise.

Doesn’t renoise render to 32bit float wav? In this case calling normalize should remove the clipping?

32bit cannot restore clipping: it does not loose resolution when changing volume, but still clipping will loose data

We could indeed save temporary invalid 32bit wavs that are not clipped (32bit wavs max gain should be -1.0/1.0 but doesn’t have to be clipped), and then normalize them afterwards, so this might be an alternative.

But what about saving the wav files the same way as in previous Renoise versions and setting the samples gain to 6dB? This would result in the sample samples as before but would sound as loud as it should be?

I’ve reverted render selection to the old (1.9) behavior now. I’ve only heard from everyone that it causes problem as it is now, so…

I understand your point of view Taktik, and yes it is safer. For me it was a was a nice surprise that the rendered sample sounded just the same (I was getting used to gaining it, I guess). The idea of setting the volume of the renderd sample to +6dB isn’t bad, since there is another 6 dB available (if one wants to make it louder).

Does this also include the render to disk?

I take it most people compose with their track volumes well over what they should be? I really don’t understand the problem… I wasn’t having any problems with the volume clipping… and I usually play shit too loud as it is!

i’d noticed that the render to sample function was clipping the audio as well just never got around to reporting it… good to hear it’s been reverted

MEH. 6db are only make up for 6db too much, right? that doesn’t solve the “problem”. It does however “punish” those who want to render stuff as loud as it is… 6db is just an arbitrary value… <_<


Yeah, if you play it on a track that goes OVER 0db and depends on the master track to cut that back - which is not good practice as far as I understand it - it will be distorted when rendered.

If you render a normalized sample on a track with no effects and post-gain at 0db, it will still be normalized. If however you play it a track that is louder than 0db, it will be distorted. Easy.

So what’s the problem? Your track is too loud, that is all…

holds up a banner saying “DON’T NERF RENOISE!”

YOu have a point there, about composing on a way to loud volume …but then …how come it is only noticible when rendered( render to selection ) and not while composing …?
Good it’s back to the old state 1.9

Have you tried setting master (without any DSP) to 0db, autogain to off, softclipping to off?

Always do
I never ,ever put anything on the master track , never goes above 0.0 dB

i like to render the effects

tracks never over 0db - just when i render a selection and move it to a clear (no dsp) track the volume is way too high and usually the audio is clipped - when taktik suggests it should be an equal level… i probably am doing something wrong, but i’m unsure to what it is and the 1.9 version of rendering sample worked fine - much easier to adjust the volume of a quiet track than one that is clipped to buggery

How can it be then? Right now, when I render a fully normalized sample on a “clean” track it ends up at 0db.

But you don’t even care for the reason, right. “it worked before so I want it back kthx”.