Render Selection To Sample Clipping

When I try to render a sine wave from Oatmeal VSti the result is clipped. The output sample sounds about as loud as the (non clipped) output of Oatmeal, which to me is mind boggling; shouldn’t Oatmeal’s output be clipping as well in this scenario? I’m 100% sure that it isn’t.

For the record, all volume sliders are set to 100%

edit: I just found out what caused the clipping; I had disabled dithering in the Audio options. Which seems odd to me… shouldn’t dithering be a global option (for VSTi too?)
edit2: Scratch that… it’s still clipping, even with dither.

maybe because you play the rendered sample through the same dsp
chain as you recorded it through, doubling the effects literally?

Yeah I catch myself doing that sometimes.

No, I don’t have any devices active. That’s the first thing I checked… not in Master either, before you ask… :\

edit: anyone know of a good (and free) file-share service? I’ll post a simple example…

Hmmm… all I can think of then is that maybe the loop is off, causing it to
click and considering the length of a sine, it could result in something
that sounds like clipping…

as for filesharing:
rapidshare
megaupload
:)

www.fileden.com is great for filesharing too.

Much more direct than rapdishare and megaupload (the upload size is restricted though)

Thanks, got an account set up (but man they have the most crooked adspace buyers ever…)
This should be the URL I hope: http://www.fileden.com/files/2008/10/14/21…g%20render.xrns
it might be interesting to know that it doesn’t clip when I render the full track with Arguru’s SINC.

addendum: you need to have Oatmeal 38-1 to listen, of course…

Did anyone try the file I uploaded? Would be nice to know if it’s only my setup that’s causing this, or if I’m overlooking something.

I didn’t download it. What Renoise version are you using ?

I tried it and it does clip when rendering. There is nothing really mysterious going on here - the output from Oatmeal is simply too loud. The amplitude parameter reads 0dB, but either that reading is incorrect and the real value is much higher, or there’s another element in Oatmeal which is adding some extra gain, possibly an EQ or filter, etc… I had a hard time finding what it could be in that horrible interface, to be honest. If you even play 2 notes simultaneously it begins to clip rather badly during realtime, not just when rendered.

I tried some other synths such as Voyager, Olga and TB4005, and I set them all to 0dB amplitude. They all generated signals at pretty much the exact same level (all lower than Oatmeal) and did not clip horribly when rendered. If you set Oatmeal’s gain to -4dB in Renoise’s instrument properties, then it’s pretty much perfectly in line with the other synths.

.

The interface does leave some to be desired, I agree with that.

When it comes to clipping, shouldn’t the render feature create a replica of what’s usually being played through the speakers? This is where I’m confused, since the output played back by Oatmeal itself isn’t passing the 0dB limit; only when the output is rendered clipping is audible as well as visible in the sample view.

Is there more headroom for a VSTi or something?

edit: the second instrument slot contains a sample I rendered from track 1. You can clearly see the cut off hills and valleys at the start.