Renoise 1.5.1 Final Was Released

Dear Renoisers,

Renoise was updated to 1.5.1.

Downloads are as usual available at http://backstage.renoise.com for regged users.
The free builds can be found at http://www.renoise.com/download.php.

Especially OSX users will love this build!

Change-log:

± OSX: Improved compatibility for OS X Tiger

± OSX: The OS X version will now also (the windows version
already does) save a crash-backup when something bad
happens and Renoise unexpectedly quits. You will
hopefully never need this feature, but its good to be
on the safe side, isn’t it? The crash-backups are saved at
“~/Library/Preferences/Renoise/VERSION/CrashBackups”

± Major GUI performance improvements, especially on OS X

± Some minor audio engine performance improvements

± Ghost Notes: Renoise supports now “ghost notes”, a
feature you might know from FT II or other trackers:
When using an instrument-envelope for an instrument,
you can now avoid that the envelopes are re-triggered
by deleting the instrument no. in the pattern:

  
 C-4 01 .. 0000 -> this will trigger instr. 01  
 --- .. .. 0000  
 D-4 .. .. 0000 -> this also, but the envelopes  
 will not be re-triggered  
  
  • Fixed a crash when auto-capture instrument was enabled and
    Instruments > 128 where used in the current pattern
  • Fixed possibly wrong pitch-rates when changing the sample rate for the
    pattern effects 01 02 05 (pitch slide and glide),
  • Various other tiny fixes and improvements

great stuff =)
any changes from 1.51 PC beta to 1.51 PC final?

no new features, but some small bugfixes.

It would have been sweet if this fix meant extending the instrument numbers to 256 (FF).

I get an error report every time I try to start Renoise a second time after install (that is, everything works fine first session); A simple dialogue box stating:

I recently tried to install renoise in a different folder, copied the logo-file over the “corrupted” file, and it seems to have worked for now. Will post if it goes wrong again.

Which OS are you running? XP 2k, 98? Can you open the bitmap in paint; is it really broken?

Don’t know if this is relevant but I’ve noticed that Renoise151Demo.exe have changed. When I first downloaded the file when 1.51b1 was released it had a slightly different size than now. So the code is also different or what? If so, the filename ought to have changed as well.
Should one only use the latest?

I didn’t downloaded the demo, i installed the 1.5.1 final right across the beta.

I installed 1.51final right across the beta too, I just downloaded the demo again to check if anything had changed. No problems here btw

hm, those minor sound bugfixes seems more and more like minor bugs, atleast when it comes to old tunes. Have you lowered the out volume to make it more sensitive to distortion? whatever has happened it seems to reek havoc over my saggy “old” ones.

back to old version :ph34r:

I’m running XP sp2, I can open the bitmap and it really don’t seem broken at all, but it works fine for some weird reason when I simply copy a “clean” version of the file over the “broken” file. But I have to do this EVERY time…

edit.
now that won’t work either, I have to re-install! :(
(which I’m getting used to now, and really is no big hassle, since I simply don’t overwrite my registered EXE and all my settings are saved, I have Renoise up and running again in 1 minute… But still!)

Did you tried cleaning out your configs (or rename your renoise 1.5.1 application folder in the documents and settings)

I’m having the exact same error!!! (on version 1.5.1 final) - OS = Win2000,

Failed to load resource file “logos/smalllogo.bmp”
But it doesn’t work at all here…

the splash screen hangs also… so i have to do ctrl-alt-del

1.5 final worked fine!
-cosmictrance

Could you please try out the build at http://www.renoise.com/download/Renoise_Demo_fix.zip ?
If it does not start, send me the “log.txt” file please. It contains some information which will hopefully help us to fix the problem.

So far I have no idea why this happens only on a few systems. Lets hope the logs will bring some light into this…

Dear Devs; :D

Last night I finnally got around to installing my copy of 1.5.1. I thought “Right, time to make a cuppa, because this will take a while…” Usually in the last few versions the setting up of Renoise has taken hours because I have to get it to accept all my VST/i plugs - and then set up all the preferences and skin.

But no! It all works straight away! No issues at all! Just straight into it, I’ve got everything. I’d barely started drinking my tea! And on top of that, it’s quicker to load than 1.5 AND quicker to close. 1.5 used to sit there and take a minute to close.

Thanks devs… shall be bug testing this…

does anybody have the installer for 1.5 demo? I have 1.5 final and can’t use it to downgrade the 1.5.1 demo and 1.5.1 seems to have stopped syncing with Cubase. if so can you email it to removed cheers!

I’ve mailed it

The new build works just fine, seems the shortcut I had pointed to my renoise 1.5-folder for some strange reason! Hope this was just plain stupidity from my part, it all works just fine now. With new shortcuts and all… :rolleyes:

it still doesnt work here … I cant install renoise 1.5.1 on mindflowers pc’s … they are win xp machines without any sps, and it simply doesnt work because of that smalllogo-problem … can anyone enlighten me how they solved this problem ? I actually had the same on my win2k machine, but I fixed it somehow … I just cant remember how, it took me nearly an hour and I cant retrace my steps …

See http://www.renoise.com/board/index.php?act…df7395f38601e96

Do not install Renoise into the “Programs” folder, or rename the “C:/Projects” folder, to make it work until we have fixed the problem.