Renoise 1.5 / Macos X


Now the MacOS X version of 1.5 alpha is ready also. I’ve sent the build to Pulsar who will put it online for registered users (as soon as he wakes up :).

I’d like to ask all of you who have waited for the OS X version to realize that this is kind of an alpha version of the alpha version. Not only does it share all the bugs that Renoise 1.5 for Win32 might have, it will most likely also have a whole lot of bugs not found in the windows version :rolleyes:

Given good bug-reports with details on how to reproduce the problems, I will try to fix everything as fast as possible.

good night,

edit - pulsar :

its done, i am awake and the osx version is available for downloading. right now registered users only, so ppl whicht macs and valid renoise licences can give it a try. public beta will be released together with the pc version.

edit - blackis :

Thankyou for all the feedback so far. Some notes on the requirements: I’ve tried to make it 10.2 (Jaguar) compatible, but I might have used some 10.3-APIs by mistake. Unfortunately I don’t have access to any machine running 10.2 where I could test it. I would be very interested in hearing any success stories, what systems does it run on and also what systems doesn’t it run on?

If it doesn’t even start on your system, I would very much appreciate the following info:

  • Any messages found in related to Renoise
  • Contents of Log.txt (if generated)
  • Messages printed in the terminal, if you run it from there (open, use “cd” to change to the directory where is, and run it using the following command: “./”

Probably the PC registered Renoise users with macs.

I guess im one of the few (or maybe the only one?) native Mac user then…


about OS X version:

the file i downloaded is an .exe-file which os x does not recognize.

help, anyone?


it went ok when i downloaded directly to my powerbook, recognized by stuffit expander.

he, he, this is gonna be funny (i hope)!


Yep it was a sit file here aswell…

i also saw it as an .exe file first when i looked at the download progressing… but when downloaded it was named as a sit file and automaticly packed itself up…

oh, blame me. going to fix it. hang on a sec!

here are some bugs on OS X version:

  1. the cursor keys seems to live their own lives when i use shortcut for changing pattern/position in.

  2. shortcut for play (should be ctrl) when swithced FT2 mode in config does not work.

  3. move continously between patterns-feature does not function

  4. tempo commands and fb00 (pattern cut) are not compatible with rns1.28.

looking forward!

:( bouhouhou…sniff… I can’t launch it…

someone could tell me how to launch renoise? double-click doesn’t works…

that is strange. maybe something with your system settings/plugins maybe?



Yep, I also installed the OS/X version (i’m so excited) I double clicked it, but it didn’t launch.

So what’s the deal? I have OSX version 10.28.

i had the same problem awhile ago with dvd studio pro 2, and i solved it by upgrading from os x 10.2.? to 10.3.4. did not make sense, but it worked…


does it mean that renoise only work with panther? :o

Just downloaded and fiddled around with this OS X version and some Beat Battle 1 tracks. So far so good, although i only played with it for 20 minutes. I’m in japan away from my PC containing my music making samples and test tracks. I’ll keep messing around as best i can but I’ll be back home in august to do more thorough tests. Also:…sg6.2@.6897fab9

Hope no one minds, but i thought the OS X app could use more help.

PS: As far as I remember, this app is PANTHER ONLY.



** Is Renoise OSX for Panther (10.3) only?? (developers?)

compile it for 10.2!

The PC version is dope! but I want to check out both so I can make my decision on what computer to buy next. :lol:

according to blackis, renoise doesnt make any panther+ specific api calls but it was developed and tested using panther. i cant make any promises here, but we will try to make it work on jaguar. right now you will need a recent os update / upgrade to use it, we are really sorry for this.

As far as I know, it should work on Jaguar, but if you could provide me with the info from the (as described above) I should be able to resolve the problems that makes it not work on your machine.

blackis… I’m sorry I don’t have your e-mail. (so I hope this is the right forum to post this)… but this was the error report:


dyld: /Applications/ can’t open library: /sw/lib/libxml2.2.dylib (No such file or directory, errno = 2)

OS Version: 10.2.8 (Build 6R73)

the same for me…

dyld: /Applications/ can’t open library: /sw/lib/libxml2.2.dylib (No such file or directory, errno = 2)

snif! :(