Renoise 1.5 / Macos X

Thankyou for the info!

The problem here is that MacOS 10.2 doesn’t seem to include libxml while it is included in 10.3. One thing you can do to solve this is to install fink ( but I wouldn’t recommend it if you aren’t familiar with the unix environment.

Now that I know what the problem is though, I’ll surely be able to work out some kind of solution. If any of you install fink, I would very much appreciate any info about what happens next, does it work?

  • Simon

I’ve installed fink 0.6.3… but nothing change…
on the console the same message :

dyld: /Applications/ can’t open library: /sw/lib/libxml2.2.dylib (No such file or directory, errno = 2)

While connected to the internet, try to write this in a Terminal:

fink install libxml2  

That should install the files it is complaining about, then try to start Renoise again.

ok done, but terminal wrote :“Information about 41 packages read in 2 seconds.
Failed: no package found for specification ‘libxml2’!”

ok I retry “fink install libxml2”
so…terminal wrote:"fink install libxml2
/usr/bin/sudo /sw/bin/fink install libxml2
Information about 1329 packages read in 1 seconds.
The following package will be installed or updated:
The following 2 additional packages will be installed:
libxml2-bin libxml2-shlibs
Do you want to continue? [Y/n] Y
/bin/rm -rf libxml2-2.5.4-1
/bin/mkdir -p /sw/src/libxml2-2.5.4-1
bzip2 -dc /sw/src/libxml2-2.5.4.tar.bz2 | /sw/bin/tar -xf -
sed ‘s|@PREFIX@|/sw|g’ </sw/fink/dists/stable/main/finkinfo/libs/libxml2-2.5.4-1.patch | patch -p1
patching file
patching file catalog.c
patching file configure
patching file
patching file update-sgml-catalog
patching file update-xml-catalog
patching file xmlcatalog.c
patching file xmllint.c
./configure --prefix=/sw --mandir=’${prefix}/share/man’ --with-iconv=/sw
checking build system type… powerpc-apple-darwin6.8
checking host system type… powerpc-apple-darwin6.8
checking for a BSD-compatible install… /usr/bin/install -c
checking whether build environment is sane… yes
checking whether make sets ${MAKE}… yes
checking for working aclocal-1.4… missing
checking for working autoconf… found
checking for working automake-1.4… missing
checking for working autoheader… found
checking for working makeinfo… found
checking for gcc… gcc
checking for C compiler default output… a.out
checking whether the C compiler works… yes
checking whether we are cross compiling… no
checking for suffix of executables…
checking for suffix of object files… o
checking whether we are using the GNU C compiler… yes
checking whether gcc accepts -g… yes
checking for a BSD-compatible install… /usr/bin/install -c
checking how to run the C preprocessor… gcc -E
checking for rm… /bin/rm
checking for mv… /bin/mv
checking for tar… /sw/bin/tar
checking for gcc option to accept ANSI C… none needed
checking for sys/types.h… yes
checking for sys/stat.h… yes
checking for stdlib.h… yes
checking for string.h… yes
checking for memory.h… yes
checking for strings.h… yes
checking for inttypes.h… yes
checking for stdint.h… yes
checking for unistd.h… yes
checking for function prototypes… yes
checking for ld used by GCC… /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld… no
checking for /usr/bin/ld option to reload object files… -r
checking for BSD-compatible nm… /usr/bin/nm -p
checking whether ln -s works… yes
checking how to recognise dependant libraries… file_magic Mach-O dynamically linked shared library
checking command to parse /usr/bin/nm -p output… ok
checking dlfcn.h usability… yes
checking dlfcn.h presence… yes
checking for dlfcn.h… yes
checking for ranlib… ranlib
checking for strip… strip
checking for objdir… .libs
checking for gcc option to produce PIC… -fno-common
checking if gcc PIC flag -fno-common works… yes
checking if gcc static flag -static works… no
checking if gcc supports -c -o file.o… yes
checking if gcc supports -c -o file.lo… yes
checking if gcc supports -fno-rtti -fno-exceptions… yes
checking whether the linker (/usr/bin/ld) supports shared libraries… yes
checking how to hardcode library paths into programs… unsupported
checking whether stripping libraries is possible… no
checking dynamic linker characteristics… darwin6.8 dyld
checking if libtool supports shared libraries… yes
checking whether to build shared libraries… yes
checking whether to build static libraries… yes
creating libtool
checking whether to enable maintainer-specific portions of Makefiles… no
checking zlib.h usability… yes
checking zlib.h presence… yes
checking for zlib.h… yes
checking for gzread in -lz… yes
checking for dirent.h that defines DIR… yes
checking for library containing opendir… none required
checking for ANSI C header files… yes
checking fcntl.h usability… yes
checking fcntl.h presence… yes
checking for fcntl.h… yes
checking for unistd.h… (cached) yes
checking ctype.h usability… yes
checking ctype.h presence… yes
checking for ctype.h… yes
checking dirent.h usability… yes
checking dirent.h presence… yes
checking for dirent.h… yes
checking errno.h usability… yes
checking errno.h presence… yes
checking for errno.h… yes
checking malloc.h usability… no
checking malloc.h presence… no
checking for malloc.h… no
checking stdarg.h usability… yes
checking stdarg.h presence… yes
checking for stdarg.h… yes
checking for sys/stat.h… (cached) yes
checking for sys/types.h… (cached) yes
checking time.h usability… yes
checking time.h presence… yes
checking for time.h… yes
checking ansidecl.h usability… no
checking ansidecl.h presence… no
checking for ansidecl.h… no
checking ieeefp.h usability… no
checking ieeefp.h presence… no
checking for ieeefp.h… no
checking nan.h usability… no
checking nan.h presence… no
checking for nan.h… no
checking math.h usability… yes
checking math.h presence… yes
checking for math.h… yes
checking fp_class.h usability… no
checking fp_class.h presence… no
checking for fp_class.h… no
checking float.h usability… yes
checking float.h presence… yes
checking for float.h… yes
checking for stdlib.h… (cached) yes
checking for sys/socket.h… yes
checking for netinet/in.h… yes
checking for arpa/inet.h… yes
checking netdb.h usability… yes
checking netdb.h presence… yes
checking for netdb.h… yes
checking sys/time.h usability… yes
checking sys/time.h presence… yes
checking for sys/time.h… yes
checking sys/select.h usability… yes
checking sys/select.h presence… yes
checking for sys/select.h… yes
checking sys/mman.h usability… yes
checking sys/mman.h presence… yes
checking for sys/mman.h… yes
checking sys/timeb.h usability… yes
checking sys/timeb.h presence… yes
checking for sys/timeb.h… yes
checking signal.h usability… yes
checking signal.h presence… yes
checking for signal.h… yes
checking for arpa/nameser.h… yes
checking for resolv.h… yes
checking for strftime… yes
checking for strdup… yes
checking for strndup… no
checking for strerror… yes
checking for finite… yes
checking for isnand… no
checking for fp_class… no
checking for class… no
checking for fpclass… no
checking for strftime… (cached) yes
checking for localtime… yes
checking for gettimeofday… yes
checking for ftime… no
checking for stat… yes
checking for _stat… no
checking for signal… yes
checking for printf… yes
checking for sprintf… yes
checking for fprintf… yes
checking for snprintf… yes
checking for vfprintf… yes
checking for vsprintf… yes
checking for vsnprintf… yes
checking for sscanf… yes
checking for gethostent… yes
checking for setsockopt… yes
checking for connect… yes
checking for type of socket length (socklen_t)… int *
checking for isnan… yes
checking for isinf… yes
checking for python… /usr/bin/python
Found Python version 2.2
checking iconv.h usability… yes
checking iconv.h presence… yes
checking for iconv.h… yes
checking for iconv… no
checking for iconv in -liconv… yes
Enabled Schemas/Relax-NG support
configure: creating ./config.status
config.status: creating libxml.spec
config.status: creating Makefile
config.status: creating include/Makefile
config.status: creating include/libxml/Makefile
config.status: creating doc/Makefile
config.status: creating example/Makefile
config.status: creating python/Makefile
config.status: creating python/tests/Makefile
config.status: creating include/libxml/xmlversion.h
config.status: creating xml2-config
config.status: creating libxml-2.0.pc
config.status: creating
config.status: creating python/
config.status: creating config.h
config.status: executing default-1 commands
make all-recursive
Making all in include
Making all in libxml
make[3]: Nothing to be done for all'. make[3]: Nothing to be done forall-am’.
Making all in .
/bin/sh ./libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I. -I./include -I./include -I/sw/include -I/sw/include -g -O2 -Wall -c SAX.c
mkdir .libs
gcc -DHAVE_CONFIG_H -I. -I. -I. -I./include -I./include -I/sw/include -I/sw/include -g -O2 -Wall -c SAX.c -fno-common -DPIC -o .libs/SAX.lo
SAX.c:1900: conflicting types for initxmlDefaultSAXHandler' /Library/Frameworks/libxml.framework/Headers/SAX.h:151: previous declaration ofinitxmlDefaultSAXHandler’
SAX.c: In function xmlDefaultSAXHandlerInit': SAX.c:1947: warning: passing arg 1 ofinitxmlDefaultSAXHandler’ from incompatible pointer type
SAX.c: At top level:
SAX.c:1960: conflicting types for inithtmlDefaultSAXHandler' /Library/Frameworks/libxml.framework/Headers/SAX.h:154: previous declaration ofinithtmlDefaultSAXHandler’
SAX.c: In function htmlDefaultSAXHandlerInit': SAX.c:2003: warning: passing arg 1 ofinithtmlDefaultSAXHandler’ from incompatible pointer type
SAX.c: At top level:
SAX.c:2018: conflicting types for initdocbDefaultSAXHandler' /Library/Frameworks/libxml.framework/Headers/SAX.h:158: previous declaration ofinitdocbDefaultSAXHandler’
SAX.c: In function docbDefaultSAXHandlerInit': SAX.c:2061: warning: passing arg 1 ofinitdocbDefaultSAXHandler’ from incompatible pointer type
make[2]: *** [SAX.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive-am] Error 2

execution of make failed, exit code 2

Failed: compiling libxml2-2.5.4-1 failed"

you may try to download these:

i assume (dont have a mac), you have to put those libraries either next to (?) or somewhere in the system path where other libraries exist.

the compilerproblem should be addressed to the fink people, if the binaries fail, they could have a clue what you need to do to compile those successfully.

yes, I’ve already done this but nothing change…
As you said I’m gonna send the previous message to Fink people…maybe they have a solution…

I still haven’t been able to run Renoise OSX so I tried this:

  1. I went shopping for a new ibook yesterday so I could run Renoise, but i decided to wait. (maybe they come out with a G5 powerbook next summer?)

  2. I used ‘fink install libxml2’ and after it was done, it said ‘no C compiler found’. so I downloaded that link that Pulsar gave out, but I haven’t tied it yet.

So that’s the status so far. I really want to test Renoise for OSX, so I will keep trying to get it to work. :)

The best way would be to update to Panther (10.3), anyway it has lots of improvements over 10.2 :slight_smile:

I understand if you are not able to do this, or do not want to do this though - I’m working hard on the 10.2 compatibility right now. Unfortunately I’m not able to promise when, or even if I will get it to work.

  • Simon

I need advices.

somethings I’ve been thinking about the past few days:

  1. 10.3 - I am not sure if it’s worth the $129. Thats not a lot of money, but I had a buddy who worked at the mac store who used to ‘hook me up’ with whatever softwares I needed. He moved :( Renoise is worth the money I paid (but is an operating system worth 129?)

  2. What’s the ‘estimated’ requirements for this MacVersion of Renoise? I still run a 2001 iBook that’s a G3 at 500mhz which came installed with OSX. Would it be a waste for me to try to run it (not much with VSTis, I usually use samples and medium number of track effects)


My advice to the first question would be to still wait for a while, if you’re not completely desperate to start using renoise :) I’m still working hard on getting it running on 10.2, and hopefully I’ll succeed.

Regarding the second question I cannot really give any good advice, on my Titanium G4 667MHz it runs fairly ok (not with massive VST usage, but ‘ordinary’ songs with samples and a number of effects plays without interruptions). The difference between G4 and G3 shouldn’t be too big right now, we’ve got a couple of AltiVec optimizations a little here and there but nothing extreme.

To sum it up, I’d suggest you still wait for a while and hopefully I’ll get it working on 10.2 and then you can see with your own eyes how well it runs on your machine.


if you want, I can mail you the iBook for a few months, if it helps you develop and test the program on a different system. But I think it’d be a better idea to wait and once you have a working version, I could just get myself a firewire sound card and see how it functions with that. I want to upgrade to a better system by next summer, but I don’t think it will take a dual-G5 to run Renoise with a few vsts