Renoise 2.0 Public Beta Testing Starts

What, still no ReWire?

i LOVE renoise 2,i cant waith for the RC to be released.i LOOOOVE it

have a nice weekend,and make some loud music :yeah:

Hi Guys,

Anyone else noticed that XRNS songs created with Renoise 2.0 are not compatible with Xrns-php , at least the merger module seems to fail to work with renoise 2.0 songs…

Any ideas ? Anyone… Help… I’m stuck here…

Feedback would be highly appreciated !


I thought the final version was ready today, turns out to be another beta! :(
Well, as long as the final version is purfect!

hi all,

i’ve installed successfully renoise 2.0b6 on fedora 10 linux. everything (well almost) is in place and with the right permissions.

when i try to launch as a normal user it says “could not launch /usr/local/bin/renoise”

at first i tought it was about permissions but it’s not. so i tried to launch it as root and see what happens, well i get this error:

[root@braith Renoise_2_0_0b6_Reg]# /usr/local/bin/renoise
-bash: /usr/local/bin/renoise: /lib/ bad ELF interpreter: No such file or directory

is it a know bug???
any solution???

please thanks

so what’s new in the 2.0 beta whatever release which just got released?

or is this a public / open beta release now? :wink:

btw, i just saw that i’m a member here (and official registered renoise user) since 6 years now?

that’s a bloody shitload of time :smiley:

/me dances

Looks like you are trying to run Renoise, which is a 32bit application in a 64bit distribution.
See please

ohps… i didn’t think of that… until last week i used a 32bit system on the laptop.
thanks taktik

Not sure if this is a bug or not, but it definitely did not behave as I expected.

I have an acapella sample that is sampled at a floating BPM (something like 125.8)
So I tried setting Renoise to that BPM.

I expected it either to accept floating BPM or not, and I got something in the middle.

The BPM field accepted a dot, but then when I finished editing the field, anything after the decimal dot disappears, but the dot stays.

In addition, Renoise seems to round the number up or down, BUT the resulting BPM does not seem to be rounded.

So inputting 125.8, makes Renoise show “126.” but then the playback seem to be at 125.8 (or at least not at the rounded BPM).

I tested it like this:

  1. Set pattern length to 256 (more noticeable)
  2. Set BPM to 128
  3. Place kick drum on the beat
  4. Record the entire pattern to sample
  5. Place the new sample on a new, parallel track
  6. Change BPM to 128.4 (less than .5 so Renoise will still show 128. and not 129.)
  7. Play and listen - the beat is not synched.

So it seems that Renoise does support floating BPM, only does not show it right. Yes?

I am using RC1

That’s right. It’s a feature and not a bug.
It’s not the most elegant solution, but it works for now.
The “.” only means that there are decimals involved.
The tooltip also explains this.
Perhaps the tooltip should show the actual BPM as well…

I see.
So its just to overcome the limitations of space in this area. Fair enough.
I am working without tooltips, so did not see it. Also, the rounding misled me.

2 digits is more than enough.
I never encountered anything that required BPM with more than 1 digit precision.

I’ve been waiting for PDC for a while now and today finally got around to installing RC1. Excellent job - everything sounds more tight now. I do still experience the minimal clicks when automating the onboard delay - but thankfully, certain plugins which remove clicks can now be used thanks to this PDC.

I have used this “new type of click” as an effect in some of my songs. I find it pretty cool to use. :)

you know its been awhile since it was updated :D

spammers don’t care <_<

Nopes indeed, user and (corresponding posts) has been deleted.