Renoise 2.8 And Numerology Au


don´t know if anybody else is using numerology with renoise.

the problem i am having though is that whenever i press esc to start editing notes while renoise is playing,
renoise automatically switch on rec and records everything numerology is doing.

if i go under preferences/midi i can unclick velocity/polyphonic aftertouch etc etc and it will stop recording
those things… but i can´t manage it to stop recording the notes. which is the biggest problem for me.

hope i´m explaining this well enough for you guys :slight_smile:

i´m probably missing something really obvious. but some guidance would really be appreciated.

best regards

I don’t really know this plugin, but I wonder if this behaviour could be fixed by checking the “Enable keyboard” tickbox below your VST device window? Maybe you’ve already tried this, though…?

hej thanks for the fast reply.

in the lower left corner of the Au plugin it says “no focus options for bridged plugin”.
thats where i normally seen the “enable” button.

whenever i use any other vst-plugins this doesn´t appear to happen at all.
the hostile recording take over thing that is :D

Oh, Ok. This indicates that either you’re using Renoise 64-bit and Numerology is 32-bit, but more likely that you’re using Renoise 32-bit and Numerology is 64-bit. Does a version exist of Numerology that would match renoise in terms of bits?

running renoise 2.8 - 32bit… at the top of the numerology au window in renoise it says " numerology ( ->32bit )… but i´m not sure if that makes it 32bit or only trying to run in 32bit mode.

i´ll search homepage and probably email jim if i can´t figure it out :slight_smile:

If you see the “->” then the plugin is running in sandboxed/bridged mode. It can still be bridged even from 32-bit to 32-bit.

Try to disable it in your Renoise Preferences: Plug/Misc > Run all plugins in sandboxes (-> separate process)

hej dblue.

neat. the arrow is gone and the “enable” button is back. however, it didn´t really change anything else.
it only says “five12: numerologyAu” now instead of “five12: numerologyAu ( -> 32bit )”.

hey guys!

sorry, but why is this thread changed to [solved]? dblue and kmaki was kind to sort me out with the sandbox issue.
but the main problem is still there. the press esc and it starts to record the notes in a track from numerologyAu/vst - sequencer.

and i´m sorry if i´m explaining this in a bad way. so, please ask and i´ll try to clearify it :slight_smile:


So you’re saying the Enable keyboard does nothing to solve your woes? Hmm.

How exactly does numerology work? Do you record something inside the vst? And esc is the trigger key for recording in Numerology?

So it should work so that you open numerology, press esc and then your renoise song starts ‘in the background’ and you’ll record something with your keyboard in Numerology, while renoise is playing? But instead of only recording stuff in numerology, it also passes the notes in renoise?

i wish i was gifted with good explaining words :slight_smile:

sadly no, the enable button didn´t change anything.

numerologyAu/Vst is a analogue sequencer. with renoise you can either trig it by program change or note change in the pattern editor.
as far as i can tell it isn´t suppose to do anything on esc.

i never have the toggle fallow mode activated in renoise. and when i press esc i expect the red bar around the pattern editor to lit up
so i can start going though whatever by click with my mouse or keyboard. edit in new notes, effect changes etc etc.
but when numerology is loaded and i press esc it starts recording and i have to press space/stop and mark and delete that section (or a couple of cmd+z).

hope this paints the picture better.

Okay, it’s starting to clear up. Do you mean that whenever you have renoises REC on, and renoise is playing, Numerology is ‘sending’ it’s sequenced data to renoise, which in turn records them?

No, wait, do you mean that the esc key behaves differently when you have numerology loaded? That would seem odd.

kmaki: yeah, thats it! :D

if i don´t turn on Rec-mode (press Esc) i can browse normally in renoise (even when numerology is loaded).
but if i press esc to go into Rec-on it seems like numerology starts “sending” it´s data/notes/velocity etc which renoise happily records.
(which is really irritating, cause i might just want to add a snare while the sound is playing. but thats just not possible… ).

wish i could make a little video of this. so you could see for youself. but my knowledge is very limited :slight_smile:

Hey, great that the problem is now more clearly defined! :D

It sounds like the issue is that your MIDI routing setup is clashing with your preferred workflow, and I’m not sure if that can be easily resolved. At this point, BTW, I’d really hope someone that has more information with external sequencers and setting them up side-by-side with renoise could stand up. I’m afraid my knowledge with such issues is rather miniscule…

But I can have a go at clarifying this further. What exactly are you playing/controlling with the numerology sequencer? I understand you have some kind of sequenced data in there. Are you for example playing a renoise instrument with Numerology?

hej, haven´t been around for a while (busy with work and life).

numerology is an analogue style sequencer in au/vst format that can control other devices like au/vst or resynth/instruments (for example).

when i start up numerology au/vst it creates a numerology midi-out which i can choose as a midi-in alternative.
it appears under /preferences/midi-in devices and /instrument settings/midi input (as it should i reckon).

guessing your are right about midi routing. but i´ve pretty much tried everything i think.
might of just missed something very obvious here though, because i´ve been staring myself blind over this. :slight_smile:

thanks again for taking your time!

I downloaded the demo to see what that beast is about, and have to say that I was completely overwhelmed… It looked really interesting, but I’d have to study it a little more to understand what’s going on.

Do you use Numerology to generate audio (I’m not even sure if that can be done… I was truly lost with the device)? Or do you use to generate MIDI? If you use it to generate only audio, I think the problem should be solvable.

If, however you use it to generate MIDI and sort of ‘play other stuff’ with Numerology, it could get complicated.

Uhm. Calling certified MIDI wizards here. :unsure: Anybody? :D


BTW. It could be that five12’s forum would be a good place to ask too! Maybe there are more people that have tried similar things. :)