Renoise And Dep with Massive VST sometimes crashes

i’m having some problem with renoise and vista DEP, and before i disable DEP completely with the “bcdedit/set {default} nx alwaysoff” command, which i’d like to avoid since everything else is working with DEP, i wonder if there is a fix around :).

my last renoise crashes with DEP got me this string, not sure if it helps or not, another time it reacted on massive.dll, altho i have tagged them not to be monitored by DEP they still are, go figure.
There is no crashlog files. Also note that i played with renoise yesterday and it never crashed with DEP, but this isn’t the first time it happened, seems a bit random (another great microsoft feature).

Problem signature:
Problem Event Name: BEX
Application Name: Renoise.exe
Application Version:
Application Timestamp: 479f9288
Fault Module Name: StackHash_e52f
Fault Module Version:
Fault Module Timestamp: 00000000
Exception Offset: 00000000
Exception Code: c0000005
Exception Data: 00000008
OS Version: 6.0.6001.
Locale ID: 1033
Additional Information 1: e52f
Additional Information 2: e98dfca8bcf81bc1740adb135579ad53
Additional Information 3: 860f
Additional Information 4: 6eabdd9e0dc94904be3b39a1c0583

well it’s crashing and crashing over and over, with any song, always the same error with DEP.

i’m running vista64 which means DEP can be disabled for 32 bits apps only, and it is disabled by default, but the 64 bits part can’t be disabled, i guess then it’s something 64bits related in renoise probably a call to the sound drivers ?..

Please let us know what exactly you have changed in the DEP config and what exactly you do in Renoise to make it crash.

It used to work before you changed the DEP settings? Is the problem that loading any DLL (a VST probably) now always gives you a DEP error?

with Default DEP on vista 64, renoise.exe crashes after 30-40s while playing a song (doing nothing else).
with DEP disabled on vista 64, it’s the same crashes (DEP can’t be disabled for 64bits apps tho).

i played with the same songs one day without a single crash, but the day after DEP keeps crashing renoise on the same songs, nothing has changed btw these 2 days and no i don’t have any viruses/trojan everything else is working perfectly fine, only renoise crashes.

since the DEP crashes gives me renoise.exe as the culprit i can’t say if it’s a vst that’s causing it, plus when a vst crashes with DEP i get the .dll in the error message instead of renoise.exe when this happened once (with massive.dll).

Does it also crash with sample-only songs? (try testing Renoise a while with one of the demo songs)

I somehow don’t really believe that DEP is the cause. Maybe its just a side effect of another (driver of VST?) problem which then shows a DEP error.

Is this a new computer you have installed Renoise on, or have you installed Windows Vista 64 on an exiting setup where a different OS used to be installed? You will not be the only one here who has a Vista 64 bit edition so this can not be a general problem (hopefully).

Have you tried if changing the Audio driver (from DirectSound to ASIO or vice versa) help?
Does disabling all MIDI devices in Renoise solve the issue?
Does enabling the “Use more compatible GFX updates” in Renoises GUI prefs change anything?

As Vincent said: Does this only happen with CPU intensive songs or with some songs which use some special VSTs?

Could you please also send me your Renoise log file (taktik renoise com)?

seems to work fine with demosong samples only, so i guess it’s one of my vst again, too bad the crashlog thing gets bypassed when it crashes.

ps: it’s massive again so consider it a NI bug as usual…
i remember once i got carried with the Kore marketting and bought it, was the most useless piece of crap i ever bought… so bugged it was unusable, NI has a long way to go to restore trust in their vst.

it’s a vst that’s causing the DEP, massive to be more precise, when i remove it everything works fine.
now a thing i don’t understand is, massive is obviously a 32bits dll (?) so how can it be watched by DEP when it doesn’t monitor 32 bits app.

since then i “fixed” it, the fun thing is i loaded kore2 for a while and it seems to have fixed massive… go figure

so yeah it’s a sideffect from a VST, nothing to do with renoise again :)

Maybe the guys at the NI / Massive support forum can help here?

I fund a DEP related compiler setting and have now explicitly disabled the DEP checks for the Renoise.exe. This normally should also apply to all its loaded components (VSTs). maybe this help as well…

the thing is when you look at the task manager with the DEP column you can see renoise is listed as disabled.