Renoise as midi slave - tempo changes from short to long pattern


(Loolarge) #1

Hi, I have a multi-track recorder that requires to be a midi clock master (Yamaha AW1600). I am running Ubuntu Studio 16.01 with jack audio.

Renoise behaves fine when jumping between patterns of equal length.

But when I jump from a shorter pattern (16 lines) to a longer one (64), the tempo slows down and then goes up withing a few seconds as if it is “re-detecting” the incoming tempo or something.

I tried changing the “Smoothing” value but it makes no difference.

I believe what it is trying to do it to stay in phase with the overall song position. It is really annoying though. If my guess is right, an option to “ignore the song position phase” would be super useful.

Am I the only one running into this?

Cheers,

IvoFX


(marbangens) #2

You are 100% sure you can’t turn of midi song position pointers from you’re Yamaha AW1600? It sound like there is a bpm conflict, if you have bpm changes from Yamaha and also in Renoise when Renoise is in slave mode Renoise could behave like that. I don’t think pattern length has anything to do with song position. You still have this problem? The problem should be in the Yamaha AW1600 cus Renoise try to sync to it + don’t have ZTxx commands in Renoise wile doing this.