Renoise Freezes on startup under new user -- Works now!


#1

Hi All,

This is mostly for posterity as I got renoise working without really knowing what I did… :huh:

It’s been a while since I have been tracking and meantime I refreshed my Arch Linux box

and created a new user to get rid of all the cruft that had gathered over the years on my

home account with around ~50GB of stuff that have now sorted out onto another disk. It’s

the same install of arch Linux that I have been using for the last 5 years. It’s serving me well.

I deleted my old user and moved the interesting data elsewhere and created a new user

and installed the configuration from the old user as the need arose. (vim, mutt, …). Today

I started renoise for the first time as my new user and it froze for some reason. I have been

trying to start it with my previous config (that worked), i,e, the .renoise and “.renoise plugin server”

dirs and also without any config as the new user, but I cannot get it to not freeze.

I also tried running with and without VST_PATH and DSSI_PATH set, but still I get a renoise that

freezes while launching. Pressing CTRL-c does not help and had to kill -9 it.

Then I ran renoise under strace with the config dirs present and VST_PATH, DSSI_PATH set

and it magivally started, I do not know why, maybe some kinf of race condition when reading

files?

Now I will be tracking! :walkman: