? renoise keyboard shortcut keys?

CTRL+Z … undo
CTRL+X … cut
CTRL+C … copy
CTRL+V … paste
CTRL+P … paste continuously to end of pattern when it fits
CTRL+i … interpolate selection (from… to… value in selection top and bottom)
CTRL+SHIFT+i … interpolate column (from… to… value in column top and bottom)
ALT+F3 … cut selection
CTRL+F3 … cut pattern
SHIFT+F3 … cut track
CTRL+SHIFT+F3 … cut column
ALT+F4 … copy selection
CTRL+F4 … copy pattern
SHIFT+F4 … copy track
CTRL+SHIFT+F4 + copy column
ALT+F5 … paste selection
CTRL+F5 … paste pattern
SHIFT+F5 … paste track
CTRL+SHIFT+F5 … paste column
SHIFT+CURSOR up down left right … make selection in track
ALT+F6 … paste selection in reverse
CTRL+F6 … paste pattern in reverse
SHIFT+F6 … paste track in reverse
CTRL+SHIFT+F6 … paste column in reverse
SHIFT+ALT+CURSOR up down left right … make smaller selection per row
F1 … restore viewpoint 1
ESC … enable Record mode
Numpad ENTER … pattern loop
rightmost ALT … play pattern
rightmost CTRL … play song
NUMPAD / … decrease octave
NUMPAD … increase octave
CTRL+1 above keys to CTRL+2… CTRL+9 CTRL+0 above keys … set pattern edit step
SCROLL LOCK … cursor follow play off/on

  • C c# D d# E F f# G g# A a# B notes on piano:
  • Z s# X d# C V g# B h# N j# M … octave keyboard, Z = C, X = D, etc
  • Q 2# W 3# E R 5# T 6# Y 7# U … octave above keyboard, Q = C, W = D, etc
  • i 9# O 0# P [ =# ] … remaining part above keyboard, i = C, O = D, etc

CAPS LOCK … note-off (=OFF=)
BACKSPACE … delete previous line
INSERT … insert line
DELETE … clear at cursor
HOME … jump to begin (this also works within the pattern Matrix but different)
F9 … jump to pattern start
F10 … jump to pattern 1/4
F11 … jump to pattern 1/2
F12 … jump to pattern 3/4
END … jump to end (this also works within the pattern Matrix but different)

from:

2 Likes

on my mac ‘backspace’ behaves exactly like ‘delete’ - no difference? any hints?

@dspasic check your keyboard settings in menu Edit… Preferences… Keys and report the bug if necessary

by default, on my pc, nothing is assigned to.
The question was rather towards MAC users and the default bindings

tyy

from the manual page:
Backspace: Delete all notes and Effect Commands at the current line in the track and scroll everything beneath the current line up.
Actually on my “default” bindings it’s shift+backspace

Btw, thanks for pointing where the preferences are

Maybe you have edited the button assignment on your computer?
It is listed in the manual as being so backspace.

are you kidding me right now?
‘reset bindings to default’ should reset bindings, right?
after pressing that button, the bindings are still the same and the backspace behaves like mentioned above.back

You probably already know this; if so, just disregard. If you’re on a Macbook, to do a Windows-like “delete” you need to hit fn-delete. So Shift+Back is really Shift+fn+delete.

Also, it only operates on the row containing the selection, not the row where the cursor happens to be, so that might explain why it looks like it’s refusing to work.

…except that’s not working for me now, either, so ???

1 Like

i like
[ctrl]+[F8] and [F9]…to shorten a Pattern Length