Renoise not responding while switching applications

Hello all,

I’ve been struggling with this issue for a long time now and it is starting to make me nuts.

What is the problem:

As long as I’m working within Renoise, nothing is going wrong. Everything functions. But when I switch to another application, for example notepad, in windows and try to go back to Renoise, Renoise isn’t responding for about 10 to 15 seconds at least. This is also displayed in the Windows Task Manager. Don’t get me wrong, Renoise isn’t crashing. Even sound is still being played normal, no crackles, no pops. If a VSTi, sample or MIDI synth is selected, I can still play them, I just can’t see any screen updates, nor click anything, start or stop the track during this 10 to 15 second period.

This is really affecting my productivity, since I sometimes need to check something in a document and switch back to renoise. Trying to stop the track sometimes isn’t possible dua to this and that’s on occasion really annoying.

Machine and software information:

Intel Core i5-2400S
Asus P8B75-V motherboard
8GB Kingston DDR3 1333 RAM
WD 640GB Black 7200rpm/64MB cache HD
Firewire card with TI chipset
ATI Radeon HD5450
Dual screen monitor setup

Connected interfaces:
Motu 828 MKII firewire sound interface
(set to ASIO 96 samples / 44.1kHz)
2 x Motu Midi Express 128 midi interface
1 x ESI M8U midi interface

Software info:
Windows 7 Home Premium 64bit
Renoise 2.8.1 64bit
a mix of 32bit and 64bit VSTfx & VSTi plugins

What I already tried :

  • lowered the graphic/theme settings in Windows
  • disabled dynamic CPU speed tools, in BIOS and Software (now running fixed at 2.5GHz)
  • disabled Windows 7 UAC
  • updated motherboard BIOS
  • installed latest drivers
  • disabled VST’s in renoise
  • tried to set a fixed framerate in renoise
  • tried the alternative gfx update thing
  • tried to play with the ASIO latency
  • disabled antivirus
  • tried setting renoise priority to Realtime
  • reinstalled renoise

Nothing changes the situation slightly. All other applications behave perfectly, switching immediately, but Renoise is driving me nuts and I need to get some productions done. As you can see I already tried a lot of things. I didn’t had the time to reinstall the complete machine yet, nor did I had any issue in the past. However the old machine was running Windows XP 32bit, so I can’t really compare.

I hope you can help solve this issue, as I’m running out of ideas, but need my work to get done …

Thanks !


I forgot to add that even when starting a new song, with no instruments (being it samples, MIDI instruments or VST’s) loaded. No song data, just a blank renoise song, the same switching issue is noticed.

How is your processor scheduling set in the System Properties/Advanced/Performance [Settings…]/Advanced panel?
Programs or Background services?
How are your visual effects configured?
How much paging ram have you set? (normalwise 1,5x your available RAM (12GB in your case) should be enough)
Do you have any kind of memory optimizer running on your machine?

When one uses memory optimizers, they usually force memory space of programs to be kicked to paging ram whenever those program’s aren’t actively used.
This however causes large delays if they have to be pulled back to front whenever they are getting focus again.
Renoise consumes a big lot of RAM and would mean a big portion moved to the page-file if it gets set to the background. Your statement about Renoise also doing the same in a clean environment worries me a bit though (at least contradicts this theory).

So i would suggest the following test:
If you would turn of memory-paging (no virtual memory) completely, i suspect your problem may be more or less over, if not at least we then know for sure we are not dealing with a paging problem.

I remember this was an issue for people who had loads of samples dumped in one folder, and the diskbrowser focused on it. Everytime you switch windows, renoise would rescan what is in the diskbrowser again. Maybe that’s what is happening here?

I think this has something to do with background services, or stuff in your startup folder that you are unaware of… I think you should try typing “msconfig” without quotes, into your start menu search box, and click, “run as administrator…”

What you want to do then is go to “services” check the box that says, “hide all microsoft services,” and disable whatever you have left… **unless, you know you need those services turned on… for example, I have symform cloud, and a couple of things from Magix AG turned on… but everything else is off

Warning!! If your anti-virus is not microsoft, and you need it, then you need to keep it on.

Now click on the startup tab… and turn off everything… ** unless… you know you want it on.

Also!! If you have not already done so… I would scan your machine for spyware, and malware, and all that garbage… just in case… using something like spybot, or malwarebytes.

What I can say is, “I’m also running win 7 home prem.” but my chipset is a much lower spec amd… I’m definitely multi-tasking here…

  • I like what vV said… I’ve had problems with memory optimizers before


This happened to me all the time on my old computer. The reason it was happening to me is related to what Jenoki said:

However, I’ve noticed that the length of the unresponsiveness period is directly related to the depth of the directory tree shown in the left pane of the disk browser view.

To illustrate this point, here is an image of a disk browser configuration that results in Renoise being extremely unresponsive on application switches:

Here is another image, the disk browser focused in the same folder as above, where Renoise is immediately responsive on application switches:

If this is your problem (and it sounds a lot like it), there are a number of ways to fix it:

Hide the top pane entirely. I have keyboard shortcuts set up for this so that it’s easy to do quickly and without using the mouse.

Sorry I didn’t mention this : I tried both in the past, but switched back to “Programs” since Background didn’t improve any performance.

At the moment “Adjust for best performance”. I don’t need fancy effects for windows.

I left it at “automatically manage” by Windows. I never had issues with this before.

No, plain and simple default Windows installation.

Tried this, same issue

Thanks Jenoki and cocoa. This indeed seems to be the issue.

I tried it when switching the top pane to Track Scopes, and indeed, I have no problems switching between applications at all if the Disk Browser isn’t selected. Why didn’t I think of this …

I even could confirm it when watching the Networking pane in the Windows Task Manager :

Both spikes are when switching from the Task Manager back to Renoise with the Disk Browser selected.

All my samples are on a NAS. I had too many disk failures in the past, and lost too many tracks and samples. Some bought, but mainly samples I created myself. This NAS gets backed up to a remote server every night. In order to prevent data loss again. At this point this library is 32.7GB with 81399 files in 2462 folders. It’s also handy to manage samples when I’m not in the studio.

Then the real question of course is, why is the Disk Browser behaving like this ? Is it something in the Renoise API or the Windows API ? Is there something that can be done to optimize this ? I previously thought, if I’m not browsing files, it shouldn’t load anything, and perhaps just show the last cached file/directory listing without actually loading the sample data. But clearly this isn’t the case.

I’ll try to switch back to the track scopes or any other view as much as possible. However, most of my drum and percussion samples are there, so sometimes I do need to browse for them.

Renoise attempts to scan sample file headers for their basic properties (channels, frequency, loop chunks) for that order it needs to access those files.
If you have them located on a NAS and it doesn’t have a fast connection (100Mbit or less), yes, this will take quite a while, but that part is not a specific Renoise problem.
Accessing files on a network in generic is an authorisation matter what slows everything down.
You will experience this problem with any program that attempts to scan file headers for this kind of data in this manner.
If you would have your samples stored locally, the problem would occur with smaller delays.

As you could see in my screenshot, my computer and NAS both have a 1Gbit connection. If I copy large chunks I get speeds in excess of 60MB/s. I will try to copy them all on a local hard drive and see how this will behave.

However, then I have again the problem of backups.

I don’t leave my studio computer on all the time. Energy is way to expensive these days. That’s where these NAS appliances excell in : fast, low noise, low power usage. I tried working with an n-way sync before, but this isn’t just working. I still like to manage samples, or create basic sample ideas on a mobile computer or computer in the living room, without the need of firing up the complete studio. N-way syncs gave me huge problems, not syncing good, deleting new content, etc.

That’s why I thought : I don’t need big local disks, I put everything on the NAS. At night a schedule runs to back them up, without me having to worry to do this manually and forgetting it.

I still don’t understand why Renoise needs to scan these files over and over again, whenever the disk browser tab is selected. I would expect only some traffic when trying to preview a sample, but not while having a browser pane open. Wouldn’t it be better to somehow cache these things, to speed up browsing the same files and folders ?

Actually (see this thread),

The disk browser issue has been brought up before, and Taktik mentioned a few possible solutions, but it seems like nothing’s come of that discussion, or at least nothing that’s been released.

Renoise rescans not only the currently selected directory for samples, but also rescans the contents of all the “opened” folders in the left pane of the disk browser so that it can update their contained folders as well.

In my experiences, the worst delays come from rescanning the entire left pane directory tree, rather than scanning the samples in the currently selected directory (although this can create smaller delays, especially for folders containing a few thousand samples).

Do you still get large delays when you keep the directory tree in the left pane very short, like I suggested in my earlier post?

Well… Turns out I was totally incorrect, but I am not going to edit my post above, just in case this thread is stumbled on, and somebody finds my suggestions helpful…


So it looks like an SMB problem in this case (simply access and authentication)
Accessing network drives is time consuming and pretty hard to circumvent unless you have a remote server that allows your proprietary client to quickly connect and exchange data (Like ftp or other file transfer protocols).
At least quick file transfer protocols are nothing that ordinary apps can offer autonomously and out-of-the-box.
Of course, it is possible to figure out if a drive is mapped or not, but should application designers really bother themselves with that? They only can bore you with messages and warnings but won’t be able to speed up the process.