Renoise on Raspberry Pi 4?

exactly! imagine something like Nerdseq but with Renoise :partying_face: :exploding_head:


Could be even better but not an obligation, Pi have keyboard and mouse ^^

I’m all for an ARM-based version of Renoise, but I wonder what the use case is for using Renoise on a Pi? Wouldn’t it just be a cheaper, less-powerful desktop experience, or are you thinking of using it in some more of a mobile application, like SunVox or LSDJ on steroids? I have always wanted to have Renoise on a small netbook or tablet to use in live performance situations, but if I’m honest, a full-powered laptop is plenty portable and can do everything I want. How would you use a Raspberry Pi version differently?

1 Like

It was simply that a 400 was just a throwback to the Amiga days for us old farts, but the fact it has no audio output kinda kills that anyway.

bought a 400 specifically for this new ARM version. You can have audio out with a simple dac, increases the fun :slight_smile:


Just got a raspberry pi 400 to check Renoise on and have a long rabbit hole to go down in this weekend. Basically first time doing anything linux, so am struggling a bit finding a workflow. But love that almost everything you need is inside the small keyboard, will get the audio through hdmi and/or see if an usb soundcard works with it. Now first to get Renoise installed :slight_smile: . It says it needs to be installed from root, but trying to paste the extracted tar inside, access is denied?

@Bungle - Throw a class-compliant USB soundcard on the back, you may well have one kicking about. Then you’ll have a setup more than comparable to an A500 with a parallel port sampler. You couldn’t really plug your headphones directly into the Amiga anyway, you had to throw something else on the back :wink:

If you don’t have one, maybe snag a cheap Scarlett 2i2 or something from ebay?

@trueschool - for me, the use case is a dedicated tracker box, one that doesn’t have all sorts of other stuff popping up and distracting me- like on the Amiga, when you threw out the OS in Noisetracker. I tried a Polyend Tracker for exactly this but it was full of hardware and software bugs. I have got further in one weekend in Renoise than I did in a month on the Tracker (before I sold it).

1 Like

Add this to your wishlist : Renoise on a Steam Deck!


I’ve recently moved to Linux. Extract the tar.gz folder then navigate to the folder and hit shift+F4 (shift-F4 opens a terminal already navigated to the folder you’re viewing) to launch terminal. Then type “sudo sh” into terminal and it will install renoise. Hope that helps.

Edit: or, from any new terminal window type “sudo sh” then drag and drop the “” folder into the terminal and it will autocomplete the command.

Disclaimer: this is all based on my use of Ubuntu Studio.

1 Like

That should Just Work™, it’s an x64 Linux box running a modified Arch-based distro, Sadly my Steam Deck reservation is currently showing Q3, but I shall surely be shoving Renoise on it. Linux holds few fears for me, having been using it since the mid 90s :smiley:

Sam thanks for the help, on my pi400 just pressing f4 brings up the terminal and using your sudo… suggestion it indeed seems to install Renoise. Problem now is that I can’t seem to open it! While the pi400 is arm based and I’m using the arm Renoise installer, I get a “cannot execute binary file - exec format error” notice in the terminal when trying to open it (whichever Renoise icon I can find). Googling I’m reading this happens when trying to open a normal x86 64 linux file on an arm based system, but I prolly need to rtfm moar.

Maybe you are running a 64bit OS on your Pi400 and downloaded the 32bit ARM Renoise installer (or the other way around)?

Yep, was apparently trying to run the wrong version :slight_smile: , Renoise backstage automatically shows the versions according to what system you’re running. In the pi400 case I can download;

Renoise 3.4.1 Linux x86_64 Stable
Renoise 3.4.1 Linux ARMhf Stable
Renoise 3.4.1 Linux ARM64 *Stable

The pi400 is 64 bit, so I downloaded and tried to install the Arm64 version first, this doesn’t work. I also tried the x86_64 build to no avail. The Armhf version does work :sunglasses:, but I need to google why, what it stands for, what is the difference with the arm64 build? Glad I have it running, now to find some ladspa & dssi plugins :slight_smile: .

1 Like

The Pi400 has a 64it ARM processor. However, until very recently, the official OS (Raspberry Pi OS) was still a 32bit OS. Hence, if you have this installed, you need 32bit binaries of Renoise (ARMhf).

hey! the newest pi os update supports arm64 now :slight_smile: happy dayzz!