Rns As Clock Master, Negative Offset Ignored?

hey, is it just me or does the negative midi clock master offset not do anything (ie. delay Renoise audio by that much)? no effect here…

… osx 10.4.11 imac

It also depends on the MIDI receiver how much delay it can compromise, if it doesn’t compromise negative timestamps then it won’t do much.
To what slave do you send the data?

It also depends on the MIDI receiver how much delay it can compromise, if it doesn’t compromise negative timestamps then it won’t do much.
To what slave do you send the data?

Renoise can not shift the MIDI clock stream ahead the audio latency. So -“Your Audio latency” is the minimum you can set up.
You should delay the MIDI clock slave instead, if possible…

Thanks guys.

Vv, there are just ‘midi realtime messages’ between 248-252 every quarter beat in the clock, no timing information (please correct me if that’s wrong)

I’m fine syncing Renoise with Ableton (using 0 at Renoise and about -34 in Ableton - the Renoise audio goes into Ableton too) but syncing with an outboard drum machine lags just that little bit extra… Renoise is at 10ms. The notes from the (nearly synced) drum machine get recorded with a little bit of delay… (edit: the drum machine also can’t anticipate the clock events, so I can’t have a negative delay there)

To make it sound better, I can enlarge the Renoise audio buffer (good point, thanks) but recorded notes from the drum machine will have that slight offset… Delaying the Renoise audio engine is the only way I can see, although I can fix the problem by editing manually for now.

Taktik, I’ve never had so much fun with a tracker in 16 years. ;)


Have you tried experimenting with Voxengo Latency Delay to provide another workaround?

Thanks for the feedback :) Just going to try for a better problem description.

So as a simple test, Renoise is sending MIDI clock to an external drum machine (Electribe ES-1) which is now triggering the Library kitClick kit in Renoise, audio latency at 1ms, MIDI clock delay at 0 (at this point the negative MIDI delay doesn’t actually do more than -1ms according to Taktik’s explanation above)…

The Renoise metronome is on, and the drum machine is just doing a simple BD + SD 4/4 pattern to trigger the kitClick. The kitClick sound falls audibly behind the Renoise metronome (because the drum machine gets the midi clock message just that much too late), like in a shuffle ;)

Now with a larger audio buffer, things get weird. Note polyphony in the kit suffers funnily (I don’t understand why - and I have the polyphony mode on) so that the kitClick SD or BD don’t play fully before being interrupted by something - it also happens with just the BD playing. At certain audio latencies (like 1) it’s fine, just slightly out of sync.

The sync is unfortunately not fixed by augmenting the audio buffer and decreasing the MIDI clock delay (that should be the ticket sound-wise, though, but not for recording), it seems that the disparity between the metronome and the BD/SD being played from the drum machine stay roughly the same no matter what, although the odd polyphony effect above changes with the audio buffer size. ;(

All this is just because I’d like to input MIDI from outboard (and Max/MSP) in sync, so I can jam with a synced setup and hit record in Renoise occasionally.

The fix here is to delay everything the audio engine does by the inverse of the MIDI delay amount, and send clock events out that much before a tick.
It’s workable (manual editing and don’t record note delays kind of thing), just takes jamming out with Renoise and MIDI out of the picture :confused:

I understand from Taktik’s response that it’s not supported for now – this goes to the top of my wishlist :)

No-one else has noticed this? Is the simple test above working for someone?
(edit: PS. the Ableton sync works because Ableton also receives and delays all the Renoise audio channels)


Did you ever find a solution for this?

I have a similar problem using Renoise as master and an Electribe ESX-1 drum machine as slave. Playing the metronome alongside the ESX makes for a slight delay between the metronome hit and the drum hits. Moving the MIDI clock offset into negative territory doesn’t change anything, the gap between metronome and drums stays the same.

Increasing the audio buffer size only increases the gap.

If you try Renoise with the PDC, you can change the track delay offset in the mixer panel (the field where you can see the “ms” post descriptor…) you can shift your MIDI track positions using either positive delays or negative delays. If you change this value in the track where you control your drummachine, all other tracks surrounded are being adjusted to this track.

I always have the PDC on. I’m aware of the track-specific delay settings (thanks to a previous forum reply by your good self), and I can indeed get everything in sync using these by adding quite large delays to audio coming from Renoise.

The funny thing is, adding a negative delay to the channel with the Line-In Device from the drum machine doesn’t seem to have any effect. It would be nice to be able to set a negative delay only on the source that’s lagging rather than having to add positive delays to everything else.

Also, the metronome will never get in sync using this method, but I can get all audio to play in time.

I should mention as well that the drum machine is not “played” from Renoise, it is only stopped/started via the MIDI clock.

I have a Virus TI Polar hanging on the MIDI out of my MPK49 and also have a laggy sound.
when I set it to -36 or something it sounds more steady but I got two questions.

when I set the offset lower e.g. -100ms what will happen?
I can’t hear a 64ms shift but I also can’t understand why it should sinds it can’t receive quicker than Renoise sents.

And if this makes a difference, anyone found a sweetspot for the Virus Polar?


Stuff doesn’t go below the lowest latency that your audiogear is set to. So if you lower stuff to match around your latency value, that would explain why your stuff is going more smooth.
Going below it i guess this would again introduce stuttering/laggy behavior or simply does nothing.

This is the thing I want to know. I can’t notice any difference when going lower.
but there has to be, otherwise this offset option would be obsolete while it just has to be low all the time.

can somebody tell about what’s the difference under the bonnet?