Sample Is Clicking - Any Way To Remove?


(RhythmSection) #1

I’ve posted a similar question before about bass, which was kindly resolved, but this time I’m triggering a sample and it’s clipping when it comes in.

I’ve tried playing with volume in the instrument editor but it doesn’t resolve the click - any ideas?

Here’s the xrns file if that helps. Any help much appreciated.


(dblue) #2

It’s clicking because the start of your bass sample is cut badly. It’s not cut exactly on a zero-crossing, therefore you get the click from the DC offset. If you simply cut on the zero-crossing instead or apply a little fade to the beginning of the sample, then the problem goes away.

Ideally, you want any sample to start at a zero-crossing. You can help to ensure this by enabling snap to zero-crossings in the sample editor, or like I said, simply applying a quick fade to your cuts.

Fixed example:
clicking_fixed.xrns

Bad:

Good:


(RhythmSection) #3

Fantastic - works perfectly, thanks so much.


(rhowaldt) #4

thanks for that dblue, i was not aware of it. even though i usually fade in the first couple miliseconds of my samples, this is a good think to keep in the back of my mind.


(td6d) #5

You might find it that the left and right channel don’t share the same 0-cross. In that case I just cut to the closest-by and put a fade on it with the ‘fade in’ or sample editor option.


(marbangens) #6

I’v done this fade in but I have clicking anyway? It’s a short stereo sample. It started to click when I eq the volume of the lower freq around 100 Hz, but if I lower that frequency the clicking disappear? Is this gain clip?


(ABįSƧȔš ṼØȊÐƎ) #7

I often fade in/out samples, though I do also use the Autofade button; “Automatically inserts a quick fade at the beginning and end of a sample. Useful for preventing unwanted audio clicks.”

It is located in the sample properties section of the sampler, just to the right of where it says ‘Playback.’

3.1_sampler-sampleproperties.png