Separate Midi Channels For Instruments


I want to trigger instruments by MIDI channel from an external MIDI sequencer… so the instrument used on track 1 is triggered by channel 1, the instrument used on track 2 is triggered by channel 2 etc. Essentially turning Renoise into a sound module.

Am I missing something obvious (other than the fact that I am morally obliged to use the tracking for sequencing, rather than some lame ‘visual’ sequencer)?



I made renoise-router for this purpose. It triggers OSC messages from MIDI & joysticks for a specific instrument. I use it in live shows with a couple midi keyboards, a guitar-hero controller, and a classic XBOX controller.

When I wrote it, I was on Linux, and it should work on Windows, if you have python+pygame+portmidi installed. I just tried it on Mac, and there are some serious issues with the portmidi pyhton stuff, so I couldn’t get it to work, there.

Looking around for a solution for Mac, I found this:

I realized that Renoise 2.8 has full instrument/track mapping support for channels. You set up the mapping under “MIDI Input” tab of the instrument you want to map. Much better!

Hey, you do realize that you are resurrecting a thread from 2006?

Indeed it is

To make a life a little easier, try this tool:

To achieve the posted case,: don’t chain and solo, just use the track and channel changer for each specific instrument. It is not much different than doing that manually in Renoise, though the Midi Management as the advantage of not needing to focus on two different areas (clicking instruments and then back to the midi in properties)

I’m confused with the device & channel mapping for an instrument in a track. I am using Renoise 2.8 on Linux and sending external MIDI via QMidiNet/ipMIDI to a second computer hosting samplers. I have 8 QMidiNet ports (each MIDI port has 16 channels of MIDI). I use this setup all of the time using the Rosegarden sequencer (which I use for orchestral stuff). But I can’t seem to set unique devices and channels for each track.

How I have things setup in Renoise:

  1. I have track 1 setup to play a Kick drum. For my external MIDI device, I have QMidiNet Port 0, with Channel 1. I get sound from my sampler no problem.

  2. I have track 2 setup to play a snare. For my external MIDI device, I have QMidiNet Port 0, channel 2. When I play, I hear the snare but no kick!

I go back to track 1, and the channel for the MIDI device is now 2. I set it back to 1, but now the channel on track 2 is set to 1. This also happens if I change the device, it seems to set all of the tracks to the same device.

Should I not be able to set a unique output device and channel for each track using external MIDI? I’m not using any groups or anything, just the default session that I created with File->New.

Thanks for any advice!

Are you use the midi management tool? If so do you have a solo or chain checkbox active? If you do have a solo box alive, the tool will automatically adjust the midi device and channel to the selected main device in the tool if you jump to other instruments, also ouside the tool.
If you don’t want that behavior, toggle all checkboxes off and simply set the device and channel in the drop-boxes for the instrument on the right side of the instrument list in the tool.

I am using the Instrument tab for each track, and then going to the Ext. MIDI icon. AFAIK, I don’t have anything solo’d or chained or anything. I just created a brand new session, and started setting up the beat tracks this way and noticed when I set MIDI devices and channels for a track, all of the other tracks got changed to the same device and channel.

make sure each midi channel goes into is own instrument slot in the top right of renoise gui

Doing the same thing… I set one device/port and it sets it the same for all of the tracks.


I’m not sure how to check that. I was wondering if this was a bug on Linux with how it’s using MIDI, it seems to be the same issue if I select the hardware MIDI on my audio interface (RME HDSP)-- if I change device/port/channel on one track using external MIDI, every other track using external MIDI gets set to the same device/port/channel.


That sounds strange indeed but i can’t duplicate this on Windows either.

Instruments work independently from tracks, so you need to create a “kick” and “snare” instrument first (just configure their respective MIDI in/outputs).
Then, when you trigger them, they should be written into the tracks you had just selected in the instr. MIDI input tab.

Changing the track doesn’t do anything, unless you have enabled the “capture instrument from pattern” option, which will attempt to locate the instrument in the current track (but, as a track can have any number of instruments playing, this is not really 100% reliable)

Yep, I got it now. I was mapping to the wrong instruments all along and mistakenly thought an instrument was bound to a track.