Sequence trigger stops held note

Hi all,

I’ve assigned sequence triggers, all good, but I’ve noticed if I’m holding down a note on my keyboard when I jump to other sequence positions that held note stops.

Is there a way around this, so I can jump about using sequence triggers, but have held notes continue to sound as I do so?


Jumping to scheduled sequences always interrupt ongoing VST note data and it’s probably the same with live input (as in, it’s not in the pattern).

You might want to check out the “Stop playing on pattern sequence navigation” option

It’s located (hidden?) in the Plugs/Misc section of Renoise preferences :slight_smile:

Ah, thanks danoise :D i had totally forgotten about that setting!

Hi guys,

Good idea, but this isn’t working for me :( perhaps it’s because I’m using instant change not scheduled. Will keep playing.



To save me re-posting the same question … getting back into Launchpad again and I wondered if there was a way all these years on to do this? If a play a sample then jump around sequences (Triggered not Scheduled) each time a pattern is triggered the sample stops. Bit of a pain for the live use I have in mind.



Hey LW

Hmm… you’re right, sample playback is interrupted when jumping instantly, via built-in MIDI mappings.
And this happens, regardless of what has been selected in preferences. Which shouldn’t happen - definitely seems like a bug.

Scheduling (not triggering), or triggering via tools (lua API) and/or keyboard shortcuts works just fine.
I guess this is also why it has flown under the radar for so long…

A workaround/alternative solution: use the Duplex Matrix app to gain control of the pattern sequence.
Instant triggering works there (since it’s API based), and it also allows looping of patterns… or use xRules, if you feel brave enough :slight_smile:


Thanks for confirming. Do I need to raise a bug or is it enough that you’re aware as a team member? Meanwhile, thanks for the suggestions…I think xRules would be fun and I need to learn more about this neat utility.



Do I need to raise a bug or is it enough that you’re aware as a team member?

It has been noted and topic moved.

Cool, ta. Ps. in xRules I tried but this has the same effect (i.e. stops sample playing), is there another part of the API that I should be looking at?



The trigger_sequence function is re-triggering the pattern, which is probably not what you want.
Rather, you want to change the currently played pattern to another one, while preserving the position (line number)

This can be done by modifying the playback_pos, like this:

local rns =
local playpos = rns.transport.playback_pos
playpos.sequence = 1 -- desired position in the pattern sequence 
rns.transport.playback_pos = playpos

Notice that you’ll have some unwanted behavior if your song contains patterns with different lengths, since the current line can’t be carried over to a pattern which is shorter. Perhaps you’ll want to modify “playback_pos_beats” instead, then.

But either approach is valid.