Set Standard Master Track Routing (asio)


I try to “teach” out Renoise to a friend but we encountered a problem.

To begin with he has a laptop with a built in sound card with separate stereo line out and headphone out. He is using Asio4All.

The problem is that when we start a new project or open one the master track is by default routed to the headphone out, which we do not prefer.

I do not seem to find a way of setting the default out for the master track. Shouldn’t there be a way of doing this? Cause if there isn’t a way then he has to switch output routing every time he fires up Renoise.

The problem exists because soundcard manufacturers have different outputs and there does not exist a kind of standard which output should always be the main output. I thought i read somewhere the output channels just get numbered and offered in high-end order only mentioning if the output (or input) is stereo or mono and nothing much else. Renoise just picks the first output offered and if that is headphone out on your vendor’s hardware, it is not something that Renoise can possibly anticipate on (or is there a way Taktik?).
With some expensive soundcards, you can assign in- and output channels through their drivers so you at least have some control over this, but the majority of audiocards have their channels fixed by design.

Set up your favorite routing once, then save this as template song: "Song “Settings” -> “Template Song” -> “Save”.

This will not change routings for existing songs, but for all songs that are newly created.

We should some offer an option to set the deault routing for the master in the preferences some when. This is a common problem with multi IO cards…

I see. I had never encountered the problem myself as I use a proper audio interface but now as I noticed the problem I thought maybe it could be solved. Thanks anyway

PS. I gave my friend my old crappy Alesis IO2 so that he at least can get it to work but it will definetely give him other problems instead. ^_^