(unaHm) #21

From what I’ve read from the release notes, you’re correct in that XRNI only started to use multiple velocity layers in 2.7. I guess you’ve got as far as you can with the tools you have for now! Fingers crossed the NRenoiseTools libraries are updated soon! :)

(atsushieno) #22

I have reported the enhancement issue to NRenoiseTools dev. and he came up with 2.7 support (only in devel repository yet) so I tried to implement SampleSplitMap support. But I cannot get it; I believe it’s almost done but Renoise only loads the first sample into an entire sample area… Since there is no public documentation on how I can correctly create SampleSplitMap elements, I find it almost impossible to do it :(

I have updated sf2xrni code in github to reflect the latest NRenoiseTools changes, as well as packaged binary here http://dl.dropbox.com/u/493047/2011/06/sf2xrni-latest.zip so that anyone can try and see what’s wrong.

Atsushi Eno

(unaHm) #23

Have you had any responses to your request Atsushi? Not really being a programmer (for now) I can’t help that much on the development side :)

A couple of the converted instruments I’ve worked on recently have loop points that are incorrect, although I know that looping in soundfonts can often be a bit ‘questionable’! Most of those I’ve found tend to put a loop right at the end of the sample, on an extremely small section of that sample. It’s not much of a problem though, as we should tweak the xrni file afterwards anyway :)

(atsushieno) #24

Oops, I once asked NRenoiseTools man but I already got a response and code, and I haven’t asked any question to anyone so far. It’s just left for some time I want to revisit with some new ideas, and I’ve been doing nothing as I’m now traveling around.

Oh you can still send me or post new issues, I’ll then try to find fixage :)

(Drop Shadow) #25

Great project. However, I can’t open the program.

I’ve downloaded and installed Mono 2.10.6.
I open Mono Command Prompt, browse to the sf2xrni’s location, try to run it, but nothing happens. What to do?

(atsushieno) #26

Hi, thanks for trying out this toy :)
The tool should be more kind for you; it just does nothing probably because you passed no sf2 file name as arguments.
Try passing some files and see if it works.

(Drop Shadow) #27

Thanks. When I run a command like sf2xrni FILE_X, a windows error dialog shows up and Mono gives me this:

UnauthorizedAccessException: Access to the path'C:\renoisebix\2009-instruments\Soundfonts\sf2xrni-0.1.7\FILE_X' was denied.  
 ved System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)  
 ved System.IO.FileStream.Init(String path, FileMode mode, FileAccess access,  
Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions  
options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)  
 ved System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access)  
 ved NAudio.SoundFont.SoundFont..ctor(String fileName)  
 ved Commons.Music.Sf2Xrni.Sf2Xrni.Import(String file, String filter)  
 ved Commons.Music.Sf2Xrni.Driver.Main(String[] args)  

I know nothing about Mono, commands and so on. So I have no idea what’s wrong.

Running XP SP3.

(atsushieno) #28

On Windows, you can run the sf2xrni.exe just like other .NET program (or it is still possible to run it with mono on windows). In either way, make sure to give executable permission on the file in its property page. It probably solves the issue.

(svuori) #29

Thanks for starting the work on this tool and making it open source. I was able to compile it on Ubuntu with a few tweaks and get it running. I dug deeper into this SampleSplitMap issue and found out that the generated maps were quite correct but renoise didn’t recognize them. The problem was with the XML file NRenoiseTools was generating. The root element had to have the attribute doc_version=“13” for it to work. I downloaded the NRenoiseTools sources and modified the XML serialization a bit and the SampleSplitMaps work now! :)/> I wonder if I should share the changes with NRenoiseTools folks. I can send you the updated NRenoiseTools.dll if you want to.

With best regards,
Sampo Vuori

(atsushieno) #30

That’s awesome, thanks for letting us know. Yeah I believe it’s worthy reporting the issue to the NRenoiseTools developers at codeplex, maybe you can even give them your changes :)