Shorcuts suddenly disappearing - wtf?

I’ve been using the same Renoise installation on my system for 3 years now, all the time using the Ctl+K from within pattern editor to clone current pattern into a new copy.

I installed the new 3.1 beta, works just as well.

Then one day, all of a sudden, in the midst of working on a song I notice that - whoa! Renoise stopped responding to pattern editor shortcuts, like, completely. Alt+Z/Alt+A - gone. Alt+K - gone.

I check the prefs, and see that indeed all Pattern editor shorts are as good as gone. WTF, thinks me. Did I accidentally press some secret combination?

Okay, I start to reassign the new ones but then whoa again! - there is no more ‘clone pattern’ shortcut! No more operation for Ctr+K to assign to! :panic: Am I hallucinating?

And guess what, as I try to assign Ctr+K to duplicate pattern (in Pattern Seq) - it just doesn’t work! You have to right-click with your mouse, only like that!

Am I missing anything here? What could have gone wrong?

EDIT: I figured it out, if you exit renoise with a non standard, e.g. Cyril symbol in an assignment it will be gone on next renoise launch. (the assignments change automatically if you change your input language while in renoise)

well, yeah, seems like it. daum! but what about Ctl+K and the whole ‘clone pattern’ function? How could that be that there is no such call anymore? I mean, does anyone clone patterns with Ctl+K? I hope someone can confirm that.

If all of your keys have been erased, then it sounds like your KeyBindings.xml may have become corrupted… somehow?

  • Go to Renoise’s Main Menu > Help > Show the Preferences Folder…
  • Close Renoise
  • Delete (or temporarily rename) the file KeyBindings.xml
  • Restart Renoise
    Renoise should then recreate all the default key bindings.

The one you’re looking for does not have “clone” in its name (unless you’ve been using a custom tool in the past?) — it’s instead called “Duplicate Current Pattern”.

Pattern Editor > Pattern Sequence > Duplicate Current Pattern — Mapped to Ctrl+K by default

Pattern Sequencer > Edit > Duplicate Current Pattern — Mapped to Ctrl+K by default

Here’s how you can reproduce it, I’ll be showing what happens to an entry (New Song)in KeyBindings.xml throughout the process.

Control + N

Open renoise

Change input language to, e.g. Russian.

Exit renoise

Control + т

Open renoise

Exit renoise

Control +

Toїvo: If you have a lot of custom keybinds you can retrieve them from the preferences folder of an older version of renoise.

same problem. if renoise is launched when input language is set to russian, all the shortcuts are missing. deleting KeyBindings.xml helps, but… it’s very annoying bug :\

hav backup? put back config files from backup.

Also, if I tool was removed from tools dir, all shortcuts of that tool will be gone (which purpose I challenge)