[Solved] Annoying Focus Bug

this bug occours some weeks ago, maybe 7 or 9 weeks, cannot remember. happened with all renoise versions, tested with 1.8 2.0 2.5
i have three installed systems (multiboot) (wxpsp2, wxpsp3, wxp64), the bug accours on two of them: wxpsp2 & wxpsp3.
on all systems are running DIFFERENT versions of ati drivers and ati tray tools for my ati4850 with
2 TFT screens in dual setup. (but the bug occours too if i dissable one monitor).

ok, what happens: all runs fine, until i start renoise, (window or fullscreen, it does not matter).
if renoise is running after clicking renoise.exe, and i does NOT click in the renoise window, i can normally
click with my mouse to any other application on my desktop and activate them. also the icons in the taskbar shows their tooltip with mouse hover.

if i click now in renoise somewhere, renoise become focus (it should have this focus already after first start??), and than i cannot click or activate with my mousepointer anything outside from renoise.
the onliest way to bring a other application to focus is to use the taskmanager.

if tooltip of the day in renoise is active, i can click to “close” and all is fine, i still can activate all other applications, but if i do a single click in renoise, the focus is “locked”.

i spend days hours to find the bug, but i give up.
so, taktik: what can i do, which part of the GUI is active if renoise is on focus?

one point which is different and which i have tried to exclude: in both affected systems a logitech mousedriver is running. in wxp64 a standart windows driver is installed.
i failed to deinstall logitech mousedriver, even in windows savemode ^^ so i cannot foreclose that this driver mess all up.
(but to be precise: i use this driver since 2003, i does not have reinstalled him, and the buf with steeling focus is new, over 6 years all was fine ^^ )

one remark: if i use taskmanager to switch to another running program, following happens:
the programm appears on his last position, and the color of his headbar becoms the active color variation.
if i than make a click in this window, the color switch to INACTIVE, after a second click, it becomes active and is working.
this hapens ONLY if renoise is running. if not, all is complete normally!

ps.: i start renoise normally with a empty project, in wxps3 i started renoise2.5 the first time, and a demosong was loaded.

-could it be a “broken” vst or vsti ?
-could it be a trojan ?
-could it be a issue with the mousedriver (dont think so. but… windows…)
-could it be a issue with some net framework or games for windows ?
-some d3d issue?

i have also a video-in pci card in my pc, where i can watch tv in a d3d overlayed window, and this have no
influence of the behavior of this renoise focus bug.
also all sort of movies with mediaplayer classic and vlc does not steel the focus. maybe i should check which overlay or draw method they use.

deleting the logitech mousewaredriver from hand kills also the keyboard driver, and with no mouse and no keyboard driver you really fucked up, after reboot, so removing this driver with the hard way is not a solution to exclude this bug-theorie.

please help!!!

my system:
q6600 , 4gig DDR2, board:MSI, ati4850 1gig.
*wxps2: ati driver from 2008 , kerio firewall
*wxpsp3: atidriver: newest availible , clean system, but net framework 1-4 installed , ms integr.firewall
wxp64: atidriver somehwere from 2009

  • renoise focus bug appears

VST or VSTi’s are not the cause, i simply renamed my vst-folder and started renoise. renoise does not found
any of my vst’s, but the “steel focus” behaviour is alive ;(

also no virusses, trojaner or spyware found ;(

directX diag found no problems (dx9.0c (4.09.0000.0904)

vice:64 ( a c64 emulator) shows the same behaviour, (steel and hold focus)

seems it is a mousedrver issue, all is good as i didn’t click with my mouse inside renoise ^^ (but this mousedriver and renoise worked together in exact this configuration since many years…

maybe the latest directX9 update messed something up… ?

okay, after no reaction from taktik …
its definitely the mousedriver for my logitech mx700, there are existing only 3 drivers for this mouse,
all have this behavior.
seems that this driver does not hormonize with some of the “latest” directx 9 updates.
a directdraw (??) programm will catch the input device of this mousedriver and lock them for the programm.

i see in renoise with process explorer in “threads” only the dinput.dll.

i have archived different installer from dx9, i tried a 2008 dx9 version, but this not solved this problem.


did you have any glue what this could be ?

ok, problem solved ^^
a very natural way … i attached a second usb mouse, installed the additional “multimedia driver” for this mouse, one reboot, and all is going very well. even without the new mouse.
no mouselocking by renoise anymore…

thanx for attention 8)