[solved] Arch Linux Segfault

[xs1t0ry@sweetpea ~]$ /usr/local/bin/renoise-2.1.0  
Renoise LOG> ===============================================  
Renoise LOG> Version : Renoise V2.1.0 (May 26 2009)  
Renoise LOG> Date : 2009-11-05  
Renoise LOG> Time : 21:50:17  
Renoise LOG> OS : Linux version 2.6.31-ARCH (root@archiOct 23 10:03:24 CEST 2009  
Renoise LOG> ===============================================  
Renoise LOG> CPU: Found 1 enabled unit(s) with 4 core(s) / 4in total.  
Renoise LOG> Application: Showing the splash window...  
Renoise LOG> StartupWindow: Initialiting the startup window.  
Renoise LOG> Graphport: Initialising XThreads...  
Renoise LOG> Graphport: Opening XDisplay ':0.0' (configured   
Renoise LOG> Graphport: XDisplay was successfully opened  
Renoise LOG> Graphport: Initializing Freeimage...  
Renoise LOG> StartupWindow: Startup window successfully initialized...  
Renoise LOG> Application: Initializing the API...  
Renoise LOG> GraphPort: Loading cursor images (libXcursor is present)...  
Renoise LOG> System: Running from '/usr/local/bin'...  
Renoise LOG> GraphPort: Initializing the Font Engine...  
Segmentation fault  


this is a known and already fixed bug, see here; the fix has not been released yet, but the thread also contains a workaround.

Thanks, I got it to work using the workaround in the thread provided.

So dirty. I must shower now.

BTW: Is there no way to edit the thread title so that I might append [SOLVED] to the end of it?

I’m glad you solved it. We usually tag the threads as [solved] on behalf of the user, so I will do it now.