[Solved] Battery No Sound Bus Master Question


Cant get any sound out of battery in renoise 2

seems like the instrument properties is where the problem lies.

sound is metering in battery but not being routed to the master

any suggestions



It depends where all these events takes place:
“Sound is metering” -> where?, the vu-meter of the track that you use it in, or inside the plugin? Did you used a send-device on that track and are the volume parameters on the specific send-track correctly set if you used one?

See http://tutorials.renoise.com/wiki/Instrument_Settings#Plugin_Routing please. By default Renoise only enables the first stereo pair of multi output plugin instruments to avoid overhead.

I think battery uses a multi channel routing by default, so make sure all channels from battery are enabled in Renoise.

Just some info in hopes that this can be solved:

On a Mac Battery 3 AU doesn’t work, even when using track routing.
VST works fine, even without using track routing.

When AU is used the channel names in track routing are just generic Bus #01, Bus #02, etc.
When VST is used, there are specific names, i.e. Bus #01 - B3 Master, Bus #02 - B3 St 3/4, etc.

According to the mouseover Battery 3 has 32 outputs and only 16 are available for track routing (not sure if this is relevant).

It doesn’t seem to matter what’s on/off in the plugin options.

I have tried with all the Battery 3 updates and it doesn’t seem to be a concern when using the AU with other hosts,
so I don’t think this is a problem with the plugin, but maybe there is something unconventional going on.

There is also a routing-problem with the Symphonic Orchestra Play plugin. Perhaps there is more regarding this.

i had the same problem with the battery AU, but i did get sound eventually.

in battery under options you can select the number of stereo outputs. as a test case i selected 1 stereo output and 0 mono outputs.

in the renoise instrument settings i had to reload battery again.

when reloaded i have sound again.

btw: it would be great to use only the renoise sample interface, and not battery. exs-24 .nki or sf2 import please! if i have a set of looped multisamples its a pain to reloop them in the sample editor.

Thanks bud that worked. :)