[solved] Blockfish On Mac

Many of you know I’m a big user of Blockfish VST. I’ve recently been trying to set up Renoise on the Mac but I’ve really missed this plugin. I went to their site to see if I could get a Mac version. I’ve tried both the AU and VST versions and can’t get them to work in the latest Renoise. Anyone else get these to work?

Some blurb from the plugin notes:

Thanks in advance for any help. :)

Hey Foo?

Remember when I was in IRC last week and you said you didn’t hang out in the forums much because you were tired of being asked newbie questions like “How do I master?” over and over again?

Well, this one is my “How do I master?” :) Literally, I think I answer this once a week.

Short answer, Blockfish plug-ins aren’t Universal Binary.

Long version, from the Wiki: http://renoise.com/wiki/Free_VSTs

About Macintosh Plug-ins

There is much confusion when it comes to Macintosh VST/VSTi due to the history of the platform.
Up until 2006 all Macintosh were built using PowerPC processors. If you have a G4 or G5 then you have a PowerPC. Nowadays, all Macintosh computers are built using Intel x86 processors.

A lot of old Plug-ins were made before 2006 and never updated. These plug-ins are known as PowerPC specific. These old plug-ins will only work on a G4 or a G5. They will not work on newer Intel Macs.

Universal binary Plug-ins are compiled in a special way which allow them to operate on both PowerPC and Intel Macs. The symbol used to indicate this feature is the Yin-Yang. These types of plug-ins work on all Macs.

As PowerPC dies out, Macintosh Plug-ins are expected to become Intel Only. These newer Plug-ins will not work on PowerPC machines.

Ok thanks for your speedy response Conner. Situation explained. I should have checked around more.

The mastering Q+As would be the minor part as to why I’m as involved here, but you’re right in pointing out my contradiction.

I was just making a joke, I was kind of worried that you disappeared that’s all, I don’t see a contradiction.

Good times.

Ok, thanks to joltz I’ve got the AU version working! Get Info on the Renoise App and checking ‘open with rosetta’ makes it all happy. :D