[Solved] Envelope drawing snaps to every 24th segment with snap off


(dysamoria) #1

When i tried to edit a volume envelope in Redux, and as the draw behavior continued to drive me crazy, i compared it to the behavior in Renoise. i know i’m a bit behind on Renoise at v 2.8, but the behavior looks logical in Renoise and NOT logical in Redux. It’stotally different. In Renoise, everything makes sense. Unless i zoom in to a very close level, there’s no snap with snap turned off. In Redux, it refuses to let me make points closer together than 24 segments/time intervals. Zoom, length, snap… none of these settings impacts the drawing snap. If i manage to select a point and change its time with the time control, it can be moved to other positions in time, but as soon as i select or drag with the draw tool, that point is relocated to this rigid 24th interval snapping.

What am i not understanding? Is this a bug? It really feels like a bug. i DID search the forum and found nothing relevant. Sorry if this is posted somewhere.

PS: what metric is the envelope using? Milliseconds or beat divisions? Samples?

i’m using Redux Demo v1.0.1in Logic 9.1.8 (32-bit), on Snow Leopard.


(toblerpone) #2

The editing resolution of the envelope in the sample modulation envelopes when not set to external editor is 5 ms. When edited in the external editor it’s 1 ms.


(dysamoria) #3

Well it’s certainly not letting me edit at that resolution. It’s behaving as though there’s a snap enabled and there isn’t.


(dblue) #4

In Renoise 2.8.2 and older, the sample modulation rate was 24 ticks per beat.

If you load your old XRNI files into Redux (or Renoise 3 and above) they will still be using the old modulation rate by default, unless you choose to upgrade them to the new standard.

6281 redux-upgrade-instrument.png

Perhaps this is the cause of the problem?

Otherwise, can you share some screenshots with us, and also upload an example XRNI which is giving you some trouble?


(dysamoria) #5

The instrument is an XI that i saved from OpenMODPlug Tracker, not an XRNI. There’s no “upgrade” button that i can see.

Basically, i’m trying to use Redux as a tool to port my tracker music from my PC to Logic on my Mac. i like trackers, i just don’t feel comfortable creating in them since i moved on to other things. Redux is doing the job so far, and i think i will be buying it, except for this envelope drawing behavior. i’ve just started a download of the demo version of Renoise 3.1 so i can see how it behaves and compare it to my registered version 2.8.

Further info on the point drawing: if i use Process to Create Random Points, they appear to be in the correct resolution. These generated points aren’t locked to the same weird snap value that i face when trying to Draw the points manually. i can move the points in time with the Time control without any problem if they sit on the grid of this weird snapping behavior of 24 ticks. If i click on a point that isn’t on this 24 ticks per space grid, they snap into place. If i try to edit points with the draw tool, they snap into place (consequentially stopping me from editing points and deleting points that do not fall within this weird snapping behavior). It doesn’t matter what zoom i use.

EDIT

i don’t know what i can provide as a screenshot. Imagine snap being turned on for every 24 ticks. It looks just like that.

EDIT 2

By the way, the actual snap doesn’t work. Turned on, it does nothing. i tested this by turning on value snap and dragging a point. It moves smoothly without any snapping at all.

EDIT 3

i attached a zip file with two XI instruments in it. They’re fine in Renoise 2.8 on my PC, but the above-described behavior of the envelope editor is apparent in Redux on my Mac.


(dblue) #6

The instrument is an XI that i saved from OpenMODPlug Tracker, not an XRNI

Then can you please share the XI with us?

It would really be great if we could test the same file you have, instead of trying to guess what is happening.

Edit: I’ve just tried importing some old XI sounds into Redux, and I can see the strange behaviour you’re talking about with the envelope points. The snapping behaviour is indeed a bit quirky.

Nevertheless, it can easily be solved by upgrading the sounds as I mentioned above. You may need to scroll right in the sample modulation chain before you see the upgrade button, as it’s positioned to the far right side of the envelope editor.

6285 redux-upgrade-modulations.png


(dblue) #7

(Edited above)


(dysamoria) #8

Then can you please share the XI with us?

It would really be great if we could test the same file you have, instead of trying to guess what is happening.

It’s the XIs. i just downloaded your version of Frnchhrn.xrni and it’s fine (thank you). Are the XIs being malformed by OMPT or are they being read weirdly by Redux?

The reason i was using XI format is that i can use Awave Studio to convert them to EXS24. But in cases where i’m going to use Redux in Logic (because Redux has freeform envelopes, which most other samplers do NOT have), i can export XRNIs instead and open them in Redux.

Cheers!

EDIT

i see that the time is now listed as beats instead of just an unlabled number. Adjusting the length controls works much more sensibly now too.


(dysamoria) #9

My apologies!

Since the XRNI you sent me showed a time button and there was no such control to be found on the imported XI, i reloaded the XI to compare again. i changed the window shape, during this. That’s when i saw what the problem is. It was exactly as you described: a format difference. The Upgrade button was cropped by consequence of my 13" screen. Much embarrassment! :blush: Thank you very much for your assistance! :slight_smile: