[Solved] Extremely weird filter issue

I’ve never come across this before, and has got me stumped. I have a track which uses Synapse Dune for synth chords. Speed of song is 140bpm at 8, with 64 lines per pattern. DSP chain is something like this:

LFO+Gainer > EQ5 > Filter

The LFO controls the gainer to get a pumping effect and does not have any cross-track behaviour.

At one point of the track I automate the filter (max cut-off, no resonance, instant inertia) to go from max cut-off to 0.17 over the course of lines 48-63 in a 64 length pattern. The next pattern has the filter remaining at 0.17

Here’s the issue. You can see the filer being automated, and the frequency roll-off on the GUI slides down at the right time (the end of the pattern it hits its destination of 0.17). However, the sound of the filter doesn’t take effect at that time - it is delayed somehow, so the filter cutoff doesn’t audible take effect until the start of the next pattern, which is what I want to avoid. It’s weird - the gui looks like everything is happening correctly, but the sound definitely isn’t affected by the filter until 8-16 lines into the next pattern.

Bizarrely, when I solo the track to diagnose the issue the filter works correctly! It is only when other things are playing that I get this odd behaviour.

There is very little routing in this song (there is only one send, and this track has nothing to do with it) and I have nothing feeding into this track, and it’s not feeding into anything else.

Any ideas?

Are you using the same instance of Dune on other tracks as well?
Has the plugin multiple outputs?
If you are using a single instance of one VST on multiple tracks, you will have the problem that only one track can affect its audio signal with DSP processing at the same time.
for multitrack processing using different DSP chains, a vst plugin needs to support audio routing in that case

If it is not that, we need some kind of desktop recorded video footage to see what is happening.

I have no idea!! I’d like to see footage as well… I just thought I’d pop in, and make this link… Easy way to make a screen video


Problem solved!

Embarassing confession: It was entirely my fault, and a completely silly mistake. I had rendered a section of the unfiltered synth and reverse it to use as a swell at the end of a section, and had forgotten all about it. This swell was misplaced in the track so it carried on into the next pattern, which gave the impression that the filter was not affecting the actual VST synth line. When I soloed the VST track, obviously the sampled swell was muted so the filter worked correctly. So, sorry for the panic :) All’s well that ends well though!

And thanks for your help ;)