[Solved] Gui: Cursor In Sample Editor Acting Weird / Tearing?

I should have put this issue up earlier. As the title shows, I’m having a problem with the cursor/playback head in the sample editor - not really sure how it’s called (the thing that shows where in sample you are when pressing a note, or simply playing it). The cursor acts hacky, it shows itself only a few times.

Not sure if it’s possible, but could it be this caused because of multiple CPU’s? Since I’m not having the problem on a PC with 1 CPU (Windows 7) and I AM having the problem on 3 PC’s who have multiple CPU’s (Windows 7). No idea how this could be caused ofcourse.

Hope someone understood me and can solve this mysterious problem. (I do have to say I had this problem in the previous Renoise version too, though until yesterday I mainly worked on a 1 CPU main PC…)

I’m talking about this:

Don’t worry… I’m sure everybody knew what you meant when you said “cursor in sample editor”.

Could you describe the problem in a little more detail? Does the cursor just completely disappear at random times? Do you notice if this happens only with certain songs, or all the time?

Have you tried changing some of the graphics preferences in Renoise? For example: GUI > More compatible GFX updates

Disappears at random times with every kind of sample in any kind of song.

Turning ‘More compatible GFX updates’ indeed makes it better (thanks for that). No random disappearances anymore, though it’s slower than I’m used too. :s

Hmm, weirdest thing. Now the cursor of the Pattern Editor is slower/hackier too… :confused:

Viniman: Do the trackscopes feel “slower” as well for you than in previois Renoise versions? Thats usually a good way to see/measure how fast Renoise updates itself graphically…

Changed that to the old 2.1 behavior now, but is that what you mean Viniman?

Like I said; it happens with any kind of sample…

And yes the trackscopes (+ pattern editor cursor) are slower when “More compatible GFX updates” is disabled. And again, I’ve had this on 3 pc’s. 2 pc’s I cannot believe no one has this problem as well.

But then everythign should be slower, the scopes the pattern editor and so on. I don’t really understand why you only mentioned the sample editor markers?

Does playing around with the “More Compatible GFX updates” in the GUI options help you here?

I’ve already rewinded changes we’ve done in that area (which actually should have speeded up the GUI a bit on some systems) to the old Renoise 2.1 behavior, to get rid of this problem:

So the next beta might work “as usual” for you again…

Okay, from start:

A few days ago I bought myself a new system (i7 processor and all the fancy shit), I noticed this weird stuff was going on in the sample editor with the cursor randomly disspearing (just as on my laptop and pc of my brother, which I noticed a few weeks/months ago). I wasn’t bothered for those few times I play with Renoise on my laptop or bro’s pc. But now I’ve got this problem too, it annoys me. So I made this topic, dblue told me about the “more compatible gfx” option (which I never even touched before), it solved the random dissapearing but it made (literally) everything slower (gfx-wise, audio output ofc still the same).

NOOOW, I checked my laptop a few mins ago, the problem is still there. I checked my brother’s pc: the problem is gone, so something fixed this…I have no clue what > so possibly it isn’t even a Renoise thing… (If it’s the case, I’m sorry for even bothering you. Now I’m on and endless search what fixed this.)


Might be a setting on your graphics card perhaps? (vsync (turn it off if it’s on) or antialias or other stuff?)

Viniman: Before we go into details; I’d say you should simply try out the next beta. I’ve reverted some GUI, graphic cards drawing behavior to how it was in Renoise 2.1…

Well I have the same problem on Renoise 2.5 beta AND Renoise 2.1, so it’s not beta specific.

I didn’t have the problem before I upgraded to Windows 7 (I had Windows 2k before, no problem at all). But maybe it has something to do with the nvidia graphic card drivers (which is the only thing I’ve updated after installing Win7) ?

I’ll try the latest gfx drivers tonight when I’m at home.

I think I know now what you mean. Depending on your monitors refresh rate and how fast the play marker scrolls, this can sometimes be hardly visible. Just have noticed this when unplugging my laptop from the power, which will set the monitor refresh rate to 50Hz instead of 60Hz.

Try opening Renoises prefs and play around with the “FrameRate” settings in the GUI pane, until you get a setting which works for your setup. unfortunately we can not choose a good default value here that makes the markers perfectly visible. This depends on too many things like the work load, gfx card, and monitor - and of course your personal preferences.

Daaamn, I’m such a dumb fuck, I did try to change the frame rate, but never had the idea to simply uncheck the frame rate and see if it worked. :confused:
That seems to do it fine now.

Weird. Seems to do the trick on my faptop too, don’t know what fixed it at my brother’s pc (he didn’t change any settings on his graphic card driver). Well, it’s fixed so I’m happy.

Thanks taktik (if there’s anything I can do to thank you, hit me!). :)