[solved] Help! "broken" File Will Not Open..


am in a bit of a pickle… last night i saved a renoise project but didnt close it down. today when i attempted to close down the program it stalled for a long time and then crashed. what i didnt expect to happen is that now i cannot re-open the file. a help box appears asking me if i would like to recover the work from the crash backup file, but when i select this i then get the ‘Ouch!..’ message box, with “unhandled thread: GUI” after that.

any help on how i may recover this file would be most appreciated as I have been working on it for some time. i understand that the culprit may be the waldorf PPG wave plugin that i was using in one of the tracks… but if so how can i remedy this!!!

macbook pro 2.4ghz; osx 10.5.8, renoise 2.1, waldorf suite 1.2.2, reason 4, ableton 6, izotope ozone 4 etc…


If it is the waldorf plugin, you can try to first rename the plugin itself so that Renoise won’t try to open it when you attempt to open the song.
Ofcourse, in the “Misc”-preferences, take care you have toggled off the “rescan at startup” option else Renoise will find the plugin and will load it anyway if a song has entries for it.

If the plugin was the problem, Renoise should open the song, yet will ofcourse tell you that it failed to open the lacking plugin.
Then just temporary pick a different plugin for the instruments that use it and save the song under a different name.
After that, rename the waldorf plugin back to the original name and Renoise will then use it again.

If it was not the Waldorf, then you can repeat the above steps for each plugin that you used in the song.
If all else fails, rename the plugin folder temporary and see if a plugin is the problem at all.
If Renoise still crashes without plugins, your song-structure (song.xml) in the xrns may be corrupt.
Usually, that is the last and worst case…

Or instead of renaming the plugin:

Start Renoise - “Prefs” -> “Misc” -> “Disable VSTs”
Load the song, remove the plugin, save the song
“Prefs” -> “Misc” -> “Enable VSTs”
Load the song again and replace/reload the plugin

cool- thanks Vv, will give that a shot in a bit and report my results. sounds complicated…!

and thanks taktik, will give that a shot too :)

cool! as it seemed simpler i gave taktik’s suggestion a shot first, and it seems to have worked. some slightly strange behaviour in that now renoise cant find the original plugins when i enable them again, and when i replaced the Ozone plugin on the master track (i forgot that i was using this as well as the waldorf) all the ozone factory presets had disappeared… a bit strange and slightly discouraging, but im sure ill be able to deal with it…

thanks for the replies, much appreciated!