[solved] Increasing Cpu Usage Over Time

I’ve noticed that renoise has been acting funny on my computer lately. I am not certain if this is a Renoise bug, but this seems like the most appropriate place to post this.

I have a very simple song, 4 channels of audio and one channel of midi. I have almost no VST effects on it. For the first 10 - 20 minutes of working on the song the CPU usage is reletively low and playback works fine. Over time the CPU usage continues to increase (when playing back the exact same pattern) and will run up to about 50%-60% which causes crackling.

If I reboot and load the exact same project up, I will get another 10 to 20 minutes of time to work before this occurs again. The only external VST I am using is the Korg M3 Editor, which really isn’t a soft synth, just a software interface to make changes to my Korg M3 from within a VST. I don’t believe this should be CPU intensive at all.

I am willing to do a few tests if requested to narrow down the problem, but am not too sure where to start. My computer should easily run at least a few channels of audio and a VST without running up to 60% CPU usage. Perhaps it is the M3 plugin? I will do a bit more testing and see if I can figure anyting out, and if so will report it here.


Got any system specifications? Like CPU edition and model, chipset, soundcard (internal / external) memory, mainboard…

I’ve tested it out a bit further.

The file can be downloaded here.

First a bit of clarification. I mentioned above I wasn’t using any external VST’s other than the M3 Editor. That was wrong, I am also using Camel Crusher on one channel.

Perhaps this isn’t a bug, but I just can’t figure out why my CPU usuage is climbing so high while working on this song. To me, I can’t see why these few VST’s should be causing incrementing CPU usage like this, unless there is something with an ultra long decay that I can’t hear that is causing incremental CPU Usage.

Test #1

Looped the pattern for 4 minutes with all VST’s enabled. Started playback at 7% cpu usage. After 4 minutes was at 60% cpu usage with crackling.

Test #2

Disabled the Korg M3 editor VST (deleted the instrument), saved the project, and rebooted. Upon rebooting I assigned standard midi control on the M3 (no VST). Started CPU usage at 10% and after 2 minutes was at 60% and crackling. Note - I only have one midi channel, nothing complicated.

Test #3

After test 2, within the project I delted Camel Crusther and again attempted playback. Within a minute cpu was already back at 45% and starting to crackle.

Any thoughts? My computer isn’t new anymore, but should easily be able to play this basic file. Specs:

Intel Pentium D 2.8 ghz, 2 gigs of ram.
Soundcard: E-mu 0404USB
External gear: Korg m3.



What happens if you hit the panic button?
Are the “auto Suspend” options checked for all used VST plugins?
VSTI have them on the lower right of the VSTI instrument properties panel, vst effect plugins require a click on the question mark to open up a dialog and check the box in there.

Another checkbox is the “Can run in multiCPU environments”

Or have you probably changed something in your CPU/Computer energy saving settings? When power saving plans are set to automatically throttle down the CPU, this will lead to apparently higher CPU usages (but the CPU idles instead). You should disable CPU throttling when working with realtime processing applications like Renoise…

Do you have a laptop …if so …take the vacuum cleaner and suck out all the dust …
I am not kidding …I had exactly the same problem ( working on a centrino laptop ) after a while the cpu became so hot, because of lack of ventilation , that is was working at half speed …because of all the dirt and dust inside …
Vacuum cleaner !!!

just tested your file…works fine so far; about 5% cpu usage over a few minutes, nothing increasing.

seems to be your “speedstepping” or what the other´s allready wrote…!

Yep …If I remember correctly …the speedstepping kicked in when there was not enough ventilation/cooling or whatever …even if it was disabled
Just get rid of all the dirt

Gentleclockdivider - You hit it out of the park!

After the suggestions on the board here I downloaded a program called speedfan. My idling CPU temperature was 80c, which to my understanding is a bit warm.

I have a desktop,not a laptop… and I think if I didn’t do audio and have such a mess of wires I’d be more inclinded to clean it up more often. Seeing as how everyone on this board has the same problem though (wires galore) I guess I can’t use that excuse. =)

After cleaning out the dust, my computer lost about 3 pounds and 45 degrees from it’s operating temperature, down to a breezy 36C. No more problems.

Seems like everytime I have a renoise problem it’s my fault. I think we should create a new bug thread called “human error”. =)


NO prob … :)


Forgot about that one yeah, but this goes for PC’s as well, unless you have water cooling, normal cool-rib packs get severely influenced by this nice cool-rib carpet of dust.
If there is any good time to open up your pc and clean out the fans and cool-ribs:it will be now or you will be sorry when the summer heat hits you very hard.

I had to check the dates on this one… lol

Word! I used to vacuum clean my case every now and then, thinking I got “most of it” - LOL!!! Yesterday I checked between fan and CPU cooling ribs… and hit gold (heh). My CPU speed nearly doubled (in a CPU benchmark where lower is better: before 82, now 46).

And there I was thinking my PC had a virus or that Windows 2000 couldn’t handle that many USB devices or other random stuff… DUST!!!

So what are you waiting for?? Do your PC some good, clean it out!

P.S.: You can use this to keep an eye on the temperature: