[Solved - Kinda] Osx: Audio Glitches On First Play Of Track

I’m experiencing an irritating issue where Renoise seems to have trouble coping with playback on the first go. For example, I load up a track and hit play, and each time there is a new section in the song (new instruments coming in, first use of tracks, in other words major changes to the number of audio events taking place) Renoise glitches like crazy as though it’s trying and failing to buffer the new sounds. Once the song has played through once, the problems disappear and everything appears to be loaded up properly.

I never had this problem in 2.72 and I’m wondering whether there have been changes to the way that songs/sounds/instruments are dynamically buffered. It’s a serious concern for me in a live context because I can’t trust 2.8 to play a song without errors on the first try.

Mac OS 10.6 32b
Renoise 2.8b6

You should also not use any Beta software for your Live performances, but i guess that is a captain obvious advise…
What plugins are you using (AU or VST) and if you click the question mark, what static buffer settings are set for those plugins, are there differences between 2.7.2 and 2.8 in these settings? and what external devices are you using? what soundcard and you use ASIO drivers?
I see you use the 32-bit version as you use 32-bit OSX…
It might also be that you may be requested to send the xrns for examination if the given information doesn’t seem to give any good clues.

Hello Mnemonic,

it’s indeed hard to guess what’s happening here without seeing the song. If you could share the song with us we maybe can maybe be more specific here.

No changes have been done here for Renoise 2.8 (none I am aware of). But are you using exactly the same audio settings in Renoise 2.8 and 2.7 on the same machine?


The only thing I can think of where this can be a problem, is when either very huge samples start to play back and you are running out of memory (the system needs to load/swap them from disk), or when heavy plugins do kick in. There are a few plugins which do consume a lot more CPU when they are triggered the first time.

Does this happen with all your songs only a few ones? The tracks that do kick in, which plugins or samples do they use?

Would be great if you could us a bit more information on all this.

Thanks for the replies. I will be able to provide more detailed information tonight, but for now I can tell you the following:

  • I don’t recall whether it happens for every song. The one in which it happens regularly I have mostly native plugins as well as a few AUMatrixReverb and two AUPitch externals. I will have to check the buffer settings tonight between 2.7.2 and 2.8b6.
  • I am using the built-in soundcard on a late-2007 Macbook. I also have a MOTU Ultralite and I will confirm tonight as to whether the problem is present with both.
  • I’m using the same machine for both. It’s a song that I made in 2.7.2 and opened in 2.8b6 without changing anything.

Like I said I’ll update tonight. Can I send the song to the admins privately?

You can send it to us at: support [at] renoise [dot] com

Alright, expect updates and xrns tonight (I’m in Canada so it will be very late in Europe).

Well this is a bit embarrassing… I just tried to recreate the problem and it’s gone. The last time that I used Renoise was perhaps two weeks ago. Between then and now I have extensively cleaned up my hard drive and uninstalled all the unnecessary apps from my machine (in preparation for a DJ set using other software).

It could well be that it was an issue with low memory or storage space. Do you still want me to send the song file?

edit: although, low memory or not I remember it working without errors in 2.7.2 — maybe something to do with the new ultrafast sample loading times?

Yes, please. Does not hurt if we double check this. Maybe we can spot something in the song which “sometimes” causes this.

Got the file. Thanks Mnemonic.

The only thing I’ve noticed is that it has a very large sample in the first instrument (the rendered song). This may under certain circumstances (when other applications do use a lot of RAM too) swap out RAM and thus can create temporary CPU spikes.

If you never got this again and this does not happen under normal circumstances, I think there’s not much more we can and should do for now here.

I agree. Thanks for checking, and of course I’ll let you know if anything like this happens again. Thanks again for your help :)