[Solved] - Linux: Bpm Automatically Turned Down?

been experimenting with running Renoise on Linux (crunchbang) and noticed a weird thing today. when i play one of my songs, at certain points it gives a short glitch, after which the BPM seems to be halved. so the song is playing at 360bpm, then glitch, it is playing at 180bpm, then glitch, it is playing at 90bpm. have not tried if it goes any further down. i’m a newbie at Linux Renoise so posting this in Beginner’s Questions because it might not be a bug.

only thing i can think of myself is that it has something to do with the song being saved on Windows. maybe data is written differently in Windows-Renoise and Linux-Renoise handles it this way?

if anyone has any idea what is happening, let me know.

edit: tried saving it in a separate file on Linux but no change. tried opening another song and it is doing the same. the BPM is definitely halving, when i let it run long enough it goes from 360, 180, 90, 45.
could it also have something to do with my Jack-settings on Linux? i’ve been experimenting with this a bit and have made a connection in the patchbay from Renoise L+R input > system output. not sure if this is right, no idea if this is causing the problem.

the Jack messages show nothing ‘out of the ordinary’. xruns but i’m used to those:

  
22:03:39.222 Transport start.  
22:03:43.974 XRUN callback (14).  
22:03:45.433 XRUN callback (2 skipped).  
22:03:53.986 XRUN callback (17).  
22:03:55.451 XRUN callback (2 skipped).  
22:04:04.043 XRUN callback (20).  
22:04:05.470 XRUN callback (3 skipped).  
22:04:14.078 XRUN callback (24).  
22:04:15.493 XRUN callback (2 skipped).  
22:04:17.498 Transport stop.  
  

the last XRUN is where it changes BPM. it happens in random parts of the song.

edit: solved. must’ve been something with Jack-settings. incidentally, i never got Jack to work properly, always had xruns. after researching this and reviewing all settings, not only is the problem solved, but my xrun-problem is gone as well.