[Solved] Linux Mlrvst: Bpm Not Passed To Plugin?

Running 64-bit Renoise 2.7.2 on Gentoo Linux.

I’m using a new JUCE-based VST. However, Renoise doesn’t seem to send it BPM. It’s not detected on Linux, but it is sent and detected on upstream’s Windows VST host, Ableton Live. However, he tried the Renoise demo for Win7, and BPM doesn’t work there. Since the plugin is JUCE, everything should work as-is between platforms and hosts. So it may definitely be a Renoise problem.

Does Renoise implement the AudioPlayHead stuff correctly, so that anything written in JUCE can actually query the VST host for BPM? Right now, it doesn’t matter what the Renoise BPM is set to; the VST only displays the default 120BPM, and sets play speeds accordingly. Would really love to get this working!

If anyone can point me to another JUCE-based Linux VST that gets/sets host BPM, I’d appreciate it, so that I can test if it’s just this new app, or if the problem is in Renoise.

Yes, we do on all platforms/architectures.

Quickly tested the plug on windows, and the tempo seems to be picked up just fine.


But please note that when you don’t feed the plugin with audio, Renoise will suspend it.
While it’s suspended, it can also not pick up BPM or trigger stuff - can’t do anything.

There’s an option to avoid this “auto suspending”. To change the option, click on the small “?” in Renoises plugin UI -> http://tutorials.renoise.com/wiki/Instrument_Settings#Plugin_Compatibility_Settings

Thank you, sir; the autosuspend behavior was causing the trouble.

On a related note, how does Renoise handle JUCE events like file drag’n’drop? The app works by dropping in external audio samples, then performing them with the monome. I can’t get D&D to work in Renoise, so I’m not sure if this is a Renoise/JUCE issue, or if it’s upstream, with the app/JUCE/Linux, since upstream has it working just fine on Windows.