[SOLVED] Linux: Native VSTs failing to initialize.

[SOLUTION] I accidentally downloaded the 32-bit MDA plugins as vV accurately assumed in post #4. If you are having a similar issue to the one defined, click here to download the 64-bit linux plugins. Thanks for the help, vV!

Let’s get right to it.

Renoise 2.8.1 + Ubuntu Studio 13.04 Raring Ringtail

I have downloaded the mda VST plugin pack (http://www.linux-vst.com/ | .so file extension ie native linux VSTs), placed them into the proper directory (/usr/lib/vst), they are being properly scanned AND showing up in Renoise.

However, when I try to initialize any of the plugins, the following occurs:

Screenshot 1: Renoise is disconnected from my Jack Server.
Screenshot 2: Internal error: Failed to connect to external audio plugin process due to inability to connect to previously disconnected Jack Server.
Screenshot 3: Failed to initialize plugin.

Redundant redundancies are redundant.

I have already tried increasing my CPU Load and Threshold time to 1000msec as mentioned in one of the miscellaneous Linux FAQ’s.

I have also already attempted starting both QJackCtl (Jack server host) and Renoise as root. The same problem occurs.


I’m surprised they appear to show up at all as the download link on the page you tell us to go to clearly says they are for Windows, not for Linux!!

You might want to try these Linux ports of the MDA plugins instead of their Windows counterparts.

I’m an idiot and searched out the MDA plugins while typing up this post rather than going back to where I had downloaded them in the first place.

The mda plugins are native linux VSTs (.so) and were downloaded from the link in your post.


Do these plugins work fine in any other host on Linux?
I’m not sure when those plugins were compiled and for which Linux system because that is unfortunately not clear. But if those compiled plugins are a little older, they might fail on the newer Linux systems, or perhaps they are compiled 32-bit and you don’t have 32-bit libraries installed on your 64-bit Linux environment. It is a wild guess, but due to the lack of various information.

Ding ding. We have a winrar. I feel stupid.

For those of you suffering similar woes, here are the MDA plugins compiled for 64-bit linux systems: