[solved] Linux: Stuck Shift modifier when pressing right shift key

  1. Start with edit mode off

  2. Bind “toggle edit mode” to right shift

  3. Put edit cursor in middle of pattern

  4. Press space (bound to “play/edit/stop” the default), pattern starts playing from the start as expected

  5. Turn edit mode on with right shift

  6. Press space, pattern starts playing from edit cursor. I would expect it to start playing from start of pattern.

  7. Press space two times more, now patterns starts playing from beginning of pattern as expected.

This does not happen when toggling edit mode with the gui button. It also does not happen when using the default esc keybinding for toggling edit mode.

Thanks for the detailed description.

I can’t replicate this here, but maybe this happens in combination with Jack Transport on your system only (see Preferences -> Audio)?

Also, is pattern follow enabled or disabled? Does it make a difference?

This happens with jack, with “jack transport sync” enabled or disabled, with alsa, and with pattern follow enabled or disabled.

Thanks for the quick reply. On a second thought it’s more likely that pressing the space key after hitting the right shift key interprets the space key as “Shift + Space” (which is mapped to “Start from Cursor” by default). Will check this on a Linux installation with Openbox.

My mistake. You are right, I also forgot I have sticky keys enabled.