[solved] Need vi plugin help

Hi, I’m here out of frustration, not because I think the Renoise forum is necessarily the proper venue, for a problem with Arturia’s Prophet-V2 vi. And its not just Renoise that won’t see it, but Logic won’t either. Neither the au nor the vst versions. But Arturia’s forum seems dead. So, as last resort, I’m hoping someone here has either experience with Arturia’s plugs in particular or working with plugins generally, that might shed some light on what’s going on?

What I’ve done:

  1. rtfm, both Arturia’s installation and authorization instructions, and Renoise’ Using VST section
  2. confirmed Arturia’s authorization of my plugs
  3. dl’d the latest version of the plugin (as recommended by Arturia) and installed over the original dl’d install
  4. searched Arturia’s forums, and posted my problem
  5. searched the internet more broadly for ANY mention of similar issues
  6. rebooted, for good measure

Current file paths:
HD>Library>Audio>Plugins>Components>Prophet-V2.component
HD>Library>Audio>Plugins>VST>Prophet-V2.vst
and
HD>Users>Username>Library>Audio>Plugins>VST>Prophet-V2.vst

Yet, neither Logic 9.1.8 nor Renoise 2.8.2/3.0 sees either au or vst versions of the P-V2 as a (new) plugin, on Mac OS X 10.6.8
I’ve trashed and rebuilt the Logic plugin cache, I’ve changed and reset vst paths in Renoise preferences.
I copied the component over to HD>User>Library>Audio>Plugins>Components…also no change in behavior.
Yet the standalone P-V2 app launches fine. All previously installed plugins appear as well, just not the P-V2 vi.

Any thoughts welcome. And sorry for posting what’s likely a manufacturer-problem on Renoise forums, but this is getting bonkers and there are a whole bunch of knowledgeable people here. I will be spanking Arturia, when I finally get a response from them. Thanks.

Perhaps you should have uninstalled the older copy first, unless it was advised to install over the original installation?
I hope you didn’t downloaded the PPC binary, because that is not going to work (i’m not sure the Arturia guys still support the old Mac 9 platforms) I also hope you are running the 64/32-bit version (or it installed these versions properly) matching the platform that you run. (I’m not sure if 32-bit plugins run on a 64-bit Mac)
The less obvious option, but since Logic fails to see the thing as well i doubt it is this problem:
Otherwise check if the plugin registered as an effect instead of a synth. (in that case drag it on the DSP area and hoppe that Renoise figures out it is an instrument instead and starts moving it to the proper section)

Thanks, yes, I’ve been thinking along those lines as well. Arturia makes it sound like you can just install ‘on top of’ an existing installation, but I don’t recall them saying that explicitly in their instructions. So I’d already been thinking of going back to square one and deinstalling everything and starting over.

Re: 32bit plugs in 64bit architecture…I thought about that as well. I’m running 64bit Renoise (2.8.2/3.0) and I’m assuming the vi is 32bit. Haven’t confirmed it though. However, from everything I’ve researched, 32bit plugs should run in a 64bit environment, and I have yet to come across anything regarding Arturia’s plugs not working due to bit depth mismatch on any platform. (had that once been an issue, I expect their forums would have queries/complaints?)

Re: ‘age’ or compatibility, this is what Arturia put on their Update page:

The P-V2 is now at version 2.5.3 which approximates what I think I saw somewhere, which was that the last update was in 2011…so, not TOO old anyway.

But thanks for the tip on dragging and dropping! I’ll try that next chance I get. Cheers.

So, nothing worked. Not a remove/reinstall, not a dragndrop, not even dl’ing the 32-bit version of Renoise 3.0 and trying to load the vi there. The only thing I noticed was different, was when reinstalling, ONLY the absolute Library path was used, and not both that AND the User/Library path, as was the case the first time I installed the vi plugin. No idea whether that’s significant. While I knew plugs can sometimes be difficult, I confess I never expected to have zero success with the first vi I’ve ever tried to install! Inexplicable.

The only thing I can conclude might be happening is a plugin conflict. Does that sound possible based on the evidence? I’ve never seen an error message. The vi iitself is just not that old, and is stated as adhering to VST 2.4 specs.

Most likely the plugin is just buggy in the first place…
Arturia doesn’t have a good reputation on their product stability either in case it does not work…
http://www.native-in…a-vstis.189800/

Here are some other troubleshooting links regarding the Prophet:


http://legacyprotoolsusers.com/index.php/forum/4-plug-ins/4873-help-with-arturia-prophet-not-showing-up

Thanks, vV…yes, I came across that Maschine post myself as I was searching for solutions. Not a good sign. Interestingly, the second link shows a different path for the plug: Application Support folder instead of the Audio folder…but don’t RTAS plugs need to see Digi hardware (or software) to work? Last night I actually ran into a post that had a guy posting queries on a similar problem with his plug over months on Arturia’s board until one day he posted that it ‘just worked’ all of a sudden and without knowing why. Not much help there :confused:

Anyway, thanks again for the links! I may try a few more things, but at this point I’m basically writing it off as a ‘lesson learned’, not to buy any plugs without trying the demo first (or doing much more thorough research).

The real reason I sprang for the P-V2 in the first place, is because I used to own a Prophet VS and thought it’d be fun to have the plugin. I suppose I could still mess around with the standalone app and route the audio into Renoise for samples? Cheers.

Just discovered that my P-V2 plugin DOES appear in the new Plugin tab (both AU and VST versions) though it still doesn’t appear in the plugin list in Edit view. But its playable, and without having yet fooled around with it much, I’m assuming the Plugin view and the Edit view are the same in functionality if not navigational convenience? I’m certainly willing to live with that :slight_smile: Oh, and the new Phrase Editor looks to rock our world!