[Solved] New Pattern Effect Commands Not Showing Up


i can not use the new pattern effect because when i try to enter the commands the place stays blank.

e.g.: i try to use the 0Oxx command and move to 2nd effect colum digit and hit the O-key … nothing happens

is there any setting i have to adjust or something?



Some obvious questions:

  • Are you actually using Renoise 2.8?
  • Do you have edit mode enabled? (Esc key by default to toggle edit)
  • Are you actually typing the letter O (‘oh’), or the number 0 (zero)?

yes, you’re right, i could provide all information on what i tried and have that seems relevant:

i use newest 2.8 64bit with 64bit windows

the problem is the same in 2.7 and maybe in older versions too

i use FT2 start/stop commands, so space toggles edit mode, i ofc was in edit mode when trying
(is there another edit mode?)

i tryed 0 and O, and i tried all letters in the alphabet, numbers and A to F work, G to Z don’t

i tryed the O and I command in volume colum too, no effect…

i tryed to use the 0Oxx command in a new song but doesnt work (issue occured 1st time with an old FT2 XM which already was converted to pre 2.8 renoise file format)

i just realized i did not install the 2.8, because i could not find other new features too
im pretty sure that the problem is between chair and keyboard
i’m back in a few minutes to edit in the result …

i was using old shortcut pointing to v2.7 - thats all - sorry for the spam …

@dblue: thx, you made me re-check things so i could solve this =)

The new pattern commands only apply to the latest song format that was introduced in 2.8, so they definitely won’t work in any previous versions such as 2.7

It’s also important to note that if you load an older song (2.7 or older) into Renoise 2.8, the new pattern commands won’t work until the song itself has been upgraded to the new 2.8 format. If you go to the Song Settings tab, you can easily see if a song needs to be upgraded:

3410 renoise-upgrade-song.png

The new pattern commands should definitely work if you create a completely new song in 2.8, though.


Ah-ha! :)

Well, glad it’s all figured out now ;)

(No worries, btw… It happens to the best of us. In the Renoise office we’re always accidentally loading the wrong damn version!)