[Solved] Problems With Loading *.Xrns Files.

Hello everybody.
I decided to write a post because of funny problem I have.

I have updated renoise (Win) to 2.6 version.
After that I was working with a song and I saved it. Next time I tried to load saved song a window appeared with communicate “Loading falied with error: “D\Muzyka … \Project.xrns” was saved with an incompatible, more recent version of Renoise”.

So right now I can’t load the project.xrns file directly in Renoise.

The most strange and nice fact is, if I try to load the project.xrns just clicking its icon in explorer, it works!

Anybody has an Idea what’s the problem?

Best regards,

You can load songs created with Renoise 2.6 with only versions 2.6 or newer.

In other words version 2.5 of Renoise will not open a song saved in Renoise 2.6

Thank you! This is a problem.
I had two versions of Renoise installed in the system. On workbench screen I had icon for Renoise 2.5 (that’s the problem with opening newer files for 2.6 directly in Renoise).
From the other side, the system (explorer) always opens *.xrns files with the most actual version of Renoise (in my case 2.6) what’s why I could open *.xrns files form explorer.

Lessons learned - don’t keep two versions of Renoise in the system, it makes a mess.

Thank you!