[solved] Registered version wants demo plugin handler?!

reboot, re-download, reinstall. Works fine now.

Ok, so I tried the demo, and was sold in under an evening—so I purchased Renoise…

Everything seems well and good, until I try to load ANY plugin instrument, which instantly fails.

OSX 10.6.8
Renoise 2.8.1 32-bit

ANY plugin…

Relevant Renoise log bits:

Error Message: Failed to access the executable file: ‘/Applications/Renoise_Reg_Intel32.app/Contents/Resources/AudioPluginServer_i386.app/Contents/MacOS/AudioPluginServer_i386’, which is necessary to load the given plugin.
Error Message: Please try to reinstall the application, using the latest installer from http://www.renoise.com/demo!

Renoise registered version has the plugin loader at:


…so you can see why this might be an issue.

Thoughts on how to fix? Is it a matter of finding a preference or config file and editing, or am I thoroughly screwed here?

FYI, plugins run fine if I uncheck sandboxing, which makes sense—since it’s the sandboxing app that Renoise_Reg_Intel32 can’t seem to find.


P.S. renaming the offending plugin loader inside the Renoise_Reg_Intel32.app (to the expected AudioPluginServer_i386) seems to fix it for now—should I just call it good and leave it alone from here?

P.P.S. NOPE. If I re-enable sandboxing of plugins, I can now load the plugin, but it refuses to launch the external interface for whatever plugin. Super. This sucks :(/>

Is your issue completely solved or do you still have a problem?
What you can try is click in the help section on the “show preferences folder”, then close Renoise once the folder shows up in the explorer/finder and rename all the Cached*.db files that show in that preferences folder to something with an underscore.

After that start Renoise and let it rescan all your vst plugins. Renoise should recreate the databases and repopulate them with new data.
If that still doesn’t work out, you are always welcome to send a message to support @ this-site dot com and see if the devs can help you out personally.

Looks like something went wrong while installing/unzipping the registered version.
Which tool have you used to unzip the downloaded Renosie zip file? Would be good to know for us, in case someone else has the same problem…

First time I used “The Unarchiver”

Second time I used Apple’s included “Archive Utility”

I guess don’t use 3rd-party unzippers in OSX :)