[Solved] Render Selection To Sample Overrides Source Material

Hi. i’ve been a renoise user for a good couple of years now… and i just updated to 2.7, theres a few things that constantly piss me off with it. but this one i find intolerable…
so i’m kinda hoping i’m just being an idiot.
I use massive a lot, and i used to render it to sample so that i could fuck with it much more :) its a cool way to change parameters in the plugin without automation. i guess it sounds backwards.
Anyway. in renoise 2.7 everytime i render to sample it replaces the original instrument.
so i basically cant really use it anymore.
just wondering if theres a solution for this… also, why do i have to double click the pattern editor to edit in it? just seems silly.

man i cant believe my first post ever is a complaining post :) i feel like a bitch.

try instead “render to new instrument”…the way it works was changed in 2.7. you can have different envelopes on each sample if done this way.

You should select ‘render plugin to new instrument’ ! In the ‘right mouse click on vsti in instrument list’ window B) .

what they said. and please remember to mark your thread [Solved] by editing your first post if this indeed works for you.

mmm that really dosent work the same… i guess ill revert back to 2.6… bummer, the slice thing is pretty dope.
so really theres no option anyway to just render stuff to seperate sample? i mean it seems the only way is to duplicate your vsti every time you want to render a note down…

I don’t understand. Do you mean “Render Plugin to New Instrument” or “Render Selection To Sample” in the Pattern Editor?

I just tried “Render Selection To Sample” in 2.7.2 and it creates a new Instrument.

I also tried “Render Plugin to New Instrument” and it creates a new instrument, too.

What OS are you using?

I don’t double click? Do you have your preferences messed up? (Preferences -> GUI -> Single Click …)

Render selection to sample.
Wait, does that mean it’s possible?
shit i looked all over my prefs.
im using os-x snow leopard.

all i want is to hit option command shift R and have a new instrument with the rendered sample.

Well it’s called Render Selection To Sample but I’ve just tried and no matter which Instrument I currently have selected it always does generate a new Instrument with the rendered sample.

I’m on WinXP SP3, not OSX, though.

back to 2.6 for me :(

But my tests proves it does work (for me at least) the way you say you want it to. Meaning either there is a difference between the PC and Mac version or somewhere you have a strange preference set. Neither of which should be reasons to go back a version but something to be fixed one way or another.

dardaratz: could you please upload a small video of what exactly you are doing? I think no one here understands you, or your Renoise behaves different from ours (for whatever reason).

“Render Selection To Sample” never should replace an existing instrument. If it does for you, this is a bug we should fix, but we then need more info from you.

I remember we had some troubles with this with the “Autocapture Instruments” option with rendering in the past. But that was during the 2.7 betas if i remember correctly and got fixed. Are you running the latest 2.7 version (2.7.2)? Is the “Options”->“Auto Capture Instrument From Pattern” option set in Renoise for you?

hey just got home from work. deleted renoise. reinstalled it and it works great.
I think it was a weird bug. i guess i was so surprised cause i never had a bug on renoise. so it didn’t even cross my mind.
anyways. after reinstalling it works great.
Thanks everyone for all the help. i was really frustrated.