[Solved] Renoise Sync The Same All Tracks

I am not sure, if this is a bug, because it is really weird and I need your help. Can you please answer me what I should do?

  1. I load sample to “track 1”
  2. I load kick to “track 2”
  3. I sync “track 1” to 64 beats
  4. And the “track 2” have the same syncing active as track 1!!
  5. As i add more samples to more tracks, I still can turn on and off syncing and change it to some value, but it get copied from one track to all others so I cannot sync differently, because syncing is same for all tracks.

Thank you community for your answer. It is really annoying, I like Renoise so far, but syncing options are probably the worst thing in Renoise.

The Sync feature is part of the sample itself, not the track. You cannot sync a track in this way.

When you sync a sample, it will be synced for the entire song, no matter which track you play it in.

But perhaps you actually mean something else?

Can you please upload an example .XRNS that demonstrates the problem? That will make it easier to understand what is happening.

Just random samples, doesnt matter what I load up. It is two different samples. Here is demo http://www.sendspace.com/file/iavglk

Thank you.

The problem here is very obvious: Your sample ‘drinkitup’ is synced to 64 lines, but it is not edited correctly. It does not loop cleanly because there’s some extra beats at the very end (where the guy says ‘baby…’). The Sync feature will force the sample to fit into the number of lines you specify. If the sample is a drum loop or something like that, then you need to be sure that the sample is cleanly edited and will loop correctly in the first place.

Here’s a very quick fix to demonstrate. I’ve simply trimmed the end of the sample so that it loops more correctly:

Thank you. Yea, the sample is not edited properly, but if you move to track 1 with kick, in instrument setting is checkd sync to 64 beats… That is the issue. Try to uncheck it, and kick sounds different… Or you dont have track A synced to 64 beats too?

Here’s what I see when I load your example song (and when I change tracks):

3358 renoise-pif-sync.png

The ‘drinkitup’ sample is synced to 64 lines.

The ‘Kick_909_FX_PL’ sample is not synced.

Changing tracks does not cause any weird behaviour with the sync settings. They just stay the same for me.

Thinking about it a bit more… It sounds like you might have the auto-capture instrument setting enabled, and this is confusing you when you move between tracks?

When auto-capture is enabled, Renoise will automatically select the instrument that is used in the track you move to. So if you manually select your kick sample and then move back into Track 1 which contains the synced loop, Renoise will automatically select the synced loop sample and you will see its properties in the instrument settings panel. Could it be this?

Please look in the main menu > Options > Auto Capture Instrument From Pattern

Disable this option and see if it helps.

Simply changing tracks in a default installation of Renoise should never mess with the sample sync settings. But I suppose it’s also possible that you have some kind of tool installed which could be changing the sample properties? If disabling auto-capture did not help, then please check which tools you have installed (if any).

Oh great, thank you so much, it was with this “Auto capture”. When I checked it, the problem dissappers, and I see the correct settings like in screenshot you posted. Great and fast reaction, job well done. Thank you, it would be nice to maybe add this information to sync section in manual, as a novice in this program it was really confusing.

I’m glad that the problem is now solved.

It wouldn’t make sense to include auto-capture in that part of the manual, because it really has nothing to do with the sync feature. In another situation you probably would have noticed the sample names changing (and other properties like transpose, volume, etc) when the auto-capture feature was active, rather than just focusing on the sync value. You just have to keep a closer eye on what’s happening :)

Auto-capture is simply one of those things you need to be aware of, a kind of ‘gotcha’ feature. I understand it can be frustrating if you accidentally turn it on and you don’t understand what has happened, but there are other areas of Renoise where similar things can happen, too. For example, you might accidentally change the computer keyboard velocity and wonder why all your notes are being recorded with a weird volume, or you might accidentally change the edit step value and wonder why the cursor is jumping several lines, or you might accidentally turn on pattern looping and wonder why your song never progresses past the first pattern, etc.

These are all things that you will understand in time. Eventually you won’t even think twice about it.

Hey man, no need to do that, extended support is what we’re here for on the forums. The manual treats the basics, the more advanced things you learn here ;)

Allright guys, thank you, very nice that community here have understanding and it is nice! >]