[Solved] Renoise V2.5.1 Render Bug With Vstis


Anybody has the same problem? When I was rendering a song always missing first note. In previous versions this works fine. Thanks.

I’m Eduard Martos Parejo, new in the forum, but a Renoise user since 2006: http://www.myspace.com/outlineweb

What operating system? Windows, Mac, Linux?

Is the first note a plugin? If so which one?

How about in v 2.6.1?

Can you post the song so others can test?

Why are you using v2.5.1? Isn’t v2.6.1 better?

My OS is Windows 7
I’m using DELL D630 Laptop
and VSTi pluggins

The Reason I still use v2.5.1 : my free updates ending with this version. I want to buy the last version when I have saved money ;)

This happens only when rendering, never playing or editing a song.
I found a workarround by creating a first pattern with all instruments of the song putting one note with volume 00.
I supose that the problem is about loading pluggins in real time while renoise is rendering a song.
I can try to make an example song test, but if the problem
not appears in latests versions I can wait until I can buy it.

Thanks to all.

eduard: Do you perhaps use some of the Korg plugins (Wavestation, Polysix, MS20 etc) as vsti, as (if I recall correctly) early versions of the plugins had this problem with missing first note when rendering?


I have the exact same problem, the first not of the song is missing, and later on another note is dropped from a subsequent pattern for no reason other than it happens when all instruments on the other tracks go quiet.

I am running:

Windows XP SP2
Pentium 4 3.40 Ghz
2 Gb RAM
Renoise 2.7.1
with the following NI plugins:

  • Battery 3 - one instance
  • Massive - 3 instances
  • FM8 - 4 instances
  • Rob Papen Blue - one instance

I’ve tried every combination of rendering, including rendering just the first pattern by itself and this still drops the first note.

Any help on diagnosing this would be greatly appreciated, thanks.

Have you tried disabling Auto Suspend?

Another trick is to add an empty pattern before the song starts.

Gah - I told a big fat lie: I had tried everything EXCEPT for Realtime render, which seems to have fixed it.

Happy days. :)